PostFix can receive but can not send emails

Discussion in 'Server Operation' started by cjsdfw, Sep 29, 2009.

  1. cjsdfw

    cjsdfw New Member

    Hi everyone,

    I spent all day trying to configure a system properly but still have some problems with Postfix configuration, at least I think so since I can not recive emails. My objective is to setup a virtual server under Virtualmin where the domain name is hosted by dyndns.org.

    The website hosting is working fine so I move to the next step: configure Postfix.
    • Configure hostname in dyndns
    • Configure MX records in dyndns
    • configure port forwarding on my router
    • enabled SMTP port 587 in Postfix (Port 25 is blocked)

    I can receive internal and external emails but I can only send emails internally. Whenever I send emails to an external address I get a connection timeout message (see log sample below).

    System Info:
    • Ubuntu 8.04 TLS
    • Webmin 1.480
    • Virtualmin 3.73 GPL

    By the way, can anyone tell me how a sending mail server know which port to send emails to? Like in my case I am using port 587 and hotmail seems to know what to use but as you can see from the mail.log below my system is sending to port 25 all the time and at least in my other server (cjsdfw.com) I am using port 587 as well and not 25.

    Any suggestion would help!
    Thanks

    :confused:
     
  2. nellyneils

    nellyneils New Member

    Hi there,
    from your logs, my first guess would be a slow internet connection might be causing the trouble.
    have you tried to check the servers Internet speed? for example try to ping external addresses like yahoo or hotmail and observer the RTT.
    In your case i think your server tries to connect to the external servers receiving mail, but due to the slow connection, its timed out and the foreign server breaks the connection.
    Also your delay in the logs is really magnificent, i think you should check the internet speeds of that server first.

    Nelson.
     
  3. falko

    falko Super Moderator

  4. yukomato

    yukomato New Member

    I have the same problem

    I have the same problem. I do received mail from internal and external. But i cannot send external. I have 25Mbits fiber, so speed is not problem. I have also checked for blacklist .. but not in the list. I have an linux mail server that works fine. Change to ubuntu got that problem

    I have ubuntu 9.10 with ispc 3

    Any one have any idea??
     
  5. falko

    falko Super Moderator

    Any errors in your mail log?
    Do you have a dynamic IP address?
     
  6. yukomato

    yukomato New Member

    dette er mail loggen.

    Dec 5 19:21:57 server postfix/smtp[2197]: 2A2CD1DD5D2: to=, relay=none, delay=162859, delays=162708/0.2/150/0, dsn=4.4.1, status=deferred (connect to b.mx.mail.yahoo.com[74.6.136.65]:25: Connection timed out)
    Dec 5 19:21:57 server postfix/smtp[2219]: connect to mx4.hotmail.com[65.55.37.88]:25: Connection timed out
    Dec 5 19:21:57 server postfix/smtp[2196]: connect to mx4.hotmail.com[65.54.188.110]:25: Connection timed out
    Dec 5 19:21:57 server postfix/smtp[2219]: 736A31DD5D3: to=, relay=none, delay=162568, delays=162418/0.04/150/0, dsn=4.4.1, status=deferred (connect to mx4.hotmail.com[65.55.37.88]:25: Connection timed out)
    Dec 5 19:21:57 server postfix/smtp[2196]: 2A2CD1DD5D2: to=, relay=none, delay=162859, delays=162708/0.17/150/0, dsn=4.4.1, status=deferred (connect to mx4.hotmail.com[65.54.188.110]:25: Connection timed out)
    Dec 5 19:25:01 server imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 5 19:25:01 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Dec 5 19:25:01 server pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 5 19:25:01 server pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Dec 5 19:25:01 server postfix/smtpd[2428]: connect from localhost[127.0.0.1]
    Dec 5 19:25:01 server postfix/smtpd[2428]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 5 19:25:01 server postfix/smtpd[2428]: disconnect from localhost[127.0.0.1]
    Dec 5 19:30:01 server pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 5 19:30:01 server pop3d: Disconnected, ip=[::ffff:127.0.0.1]

    I have static ip.
     
  7. falko

    falko Super Moderator

    Does this happen only with Hotmail accounts, or also with other email providers?
     
  8. yukomato

    yukomato New Member

    I have tried to send all emails account external ..

    hotmail, yahoo google .. so on .. Real problem is: I cannot send any mail external. Internal is no problem ..

    I do received mail from xternal accounts........
     
    Last edited: Dec 6, 2009
  9. falko

    falko Super Moderator

    Do you have PTR and SPF records?
     
  10. sjau

    sjau Local Meanie

    Most email servers will not accept email coming from a server on a dynamic ip. They consider that as spam (well, I have configured my servers the same). So the only option I see is that you have to relay the outgoing email trhough your isp.

    Edit: I didn't see that you have a static IP. However, if you still can't figure it out, you may give relaying a try anyway :)
     
  11. topdog

    topdog HowtoForge Supporter

    This is a clear case of your outbound port 25 connection being blocked.
    Code:
    Dec 5 19:21:57 server postfix/smtp[2219]: connect to mx4.hotmail.com[65.55.37.88]:25: Connection timed out
    Dec 5 19:21:57 server postfix/smtp[2196]: connect to mx4.hotmail.com[65.54.188.110]:25: Connection timed out
     

Share This Page