Postfix Backscatter

Discussion in 'General' started by Mensoif, Nov 27, 2010.

  1. Mensoif

    Mensoif New Member

    Hi,

    My server is in the backscatterer.org database. It's a Debian Perfect setup installation with ISPConfig 2. I tried to read the Postfix Backscatter Howto, but it's not simple to understand as the configuration is not the same. In this howto, they speak about local_recipient_maps but ISPConfig uses virtual_maps. They also speak about unknown_local_recipient_reject_code = 550 wich should be the default in everything > postfix 2.4, as I use 2.7 this should not be the problem.

    I don't see what could be the problem, does someone have a clue about what could be wrong?
    Is there an easy Test I could do to test my server for Backscatter?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post your main.cf?
     
  3. Mensoif

    Mensoif New Member

    Thank's for your reply, here it is :
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = delta.myhost.fr
    alias_maps = hash:/etc/aliases hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = delta.myhost.fr, localhost.myhost.fr, localhost.localdomain, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    smtpd_sasl_authenticated_header = yes
    relay_domains = lists.myhost.fr
    transport_maps = hash:/etc/postfix/transport
    mailman_destination_recipient_limit = 1
    
     
  4. edge

    edge Active Member Moderator

    An option could be changing the "$final_spam_destiny" value from "D_BOUNCE" to "D_DISCARD" in /etc/amavis/conf.d/20-debian_defaults

    Change: "$final_spam_destiny = D_BOUNCE;" to "$final_spam_destiny = D_DISCARD;"

    Basicaly spam is now not bounced back, but deleted.
     
  5. Mensoif

    Mensoif New Member

    Thanks for your reply, but as far as I know ISPConfig 2 does not use amavis, or am I missing something?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    A listing at backscatter.org can also be caused by normal autoresponders. So the listing does not nescessarily mean that something is wrong with the setup.
     
  7. Mensoif

    Mensoif New Member

    Thanks Till, I didn't think about the autoresponder, but unfornatelly it's not the case, I'searched the db, and user_autoresponder is either set to 0 or NULL.

    could the problem be that I switched to spamd?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am not sure if spamd is able to send messages back to spammers, but you should check the spamd / spamassassin configuration in /etc/... if there is such a option.
     

Share This Page