Postfix Authentication - Relay not allowed

Discussion in 'Server Operation' started by bschultz, Oct 2, 2007.

  1. bschultz

    bschultz Member

    I followed the Postfix Virtual MySQL howto, and I'm having problems with sending mail. I get a relay not allowed in the mail log.

    Here's my postfix.conf file

    Yes, I do have the authentication turned on in my email client (using the same login info as receiving).

    Any ideas? I've looked over nearly 15 pages of a search on the forums, but couldn't find an answer that seemed to fit my problem.

    Thanks!
     
  2. bschultz

    bschultz Member

    I followed Falko's advice on another thread and removed the domain from mydestination, now I get this error:

    Any ideas?

    Thanks!
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? If it's Debian or Ubuntu, what's in /etc/postfix/sasl/smtpd.conf?
     
  4. bschultz

    bschultz Member

    Thanks for the reply Falko. I'm using Etch

     
  5. falko

    falko Super Moderator ISPConfig Developer

    It should read
    Code:
    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: mysql
    sql_hostnames: 127.0.0.1
    sql_user: mail_admin
    sql_passwd: mail_admin_password
    sql_database: mail
    sql_select: select password from users where email = '%u'
    instead.
     
  6. bschultz

    bschultz Member

    I changed the file (not sure how I got those other 2 entries in there) and rebooted the machine. It still didn't work. What other files do you want to see the settings in?

    Thanks again, Falko!
     
  7. giganet

    giganet New Member

    I'm just curious...

    Is the 'relay not allowed' in your log coming from your system or possibly your ISP?

    I have found many mainstream ISP's don't allow relaying, so if you are trying to use a MSN account to send a piece of email from any email account other than one originating from MSN will not be allowed as that ISP has closed relaying in their email server.



    Regards
     
  8. bschultz

    bschultz Member

    I've got a local ISP that I pay for a static address (which they only give to people who run their own servers), so that's not the issue.

    Thanks, though!
     
  9. giganet

    giganet New Member

    If you are using your ISP's mail server as your outgoing SMTP it would cause the no relay issue if your ISP does not allow relaying though.


    Not trying to be a pest :)

    Regards
     
  10. bschultz

    bschultz Member

    I appreciate the help, but I'm not using my ISP for my outgoing server...and they do allow relaying if I were to do that.

    Thanks again, though!
     
  11. falko

    falko Super Moderator ISPConfig Developer

    What's the error message now?

    What's in /etc/default/saslauthd?
     
  12. bschultz

    bschultz Member

    Now I'm getting a Certificate error too...

    Code:
    
    Oct  5 08:41:59 mail postfix/smtpd[5398]: cannot load Certificate Authority data
    Oct  5 08:41:59 mail postfix/smtpd[5398]: warning: TLS library problem: 5398:error:02001002:system library:fopen:No such file or directory:bss_file.c:122:fopen('/etc/postfix/ssl/cacert.pem','r'):
    Oct  5 08:41:59 mail postfix/smtpd[5398]: warning: TLS library problem: 5398:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:125:
    Oct  5 08:41:59 mail postfix/smtpd[5398]: warning: TLS library problem: 5398:error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib:by_file.c:274:
    Oct  5 08:41:59 mail postfix/smtpd[5398]: warning: 209.191.211.194: hostname mail.kkbjam.com verification failed: Name or service not known
    Oct  5 08:41:59 mail postfix/smtpd[5398]: connect from unknown[209.191.211.194]
    Oct  5 08:41:59 mail postfix/smtpd[5398]: warning: unknown[209.191.211.194]: SASL LOGIN authentication failed: authentication failure
    
    mail.kkbj.com is my work address, trying to send using my home server. I'll post the message from my home network when I get home in an hour or so.


    /etc/default/saslauthd

    Code:
    #
    # Settings for saslauthd daemon
    #
    
    # Should saslauthd run automatically on startup? (default: no)
    START=yes
    
    # Which authentication mechanisms should saslauthd use? (default: pam)
    #
    # Available options in this Debian package:
    # getpwent  -- use the getpwent() library function
    # kerberos5 -- use Kerberos 5
    # pam       -- use PAM
    # rimap     -- use a remote IMAP server
    # shadow    -- use the local shadow password file
    # sasldb    -- use the local sasldb database file
    # ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
    #
    # Only one option may be used at a time. See the saslauthd man page
    # for more information.
    #
    # Example: MECHANISMS="pam"
    MECHANISMS="pam"
    
    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""
    
    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5
    
    # Other options (default: -c)
    # See the saslauthd man page for information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    # Note: See /usr/share/doc/sasl2-bin/README.Debian
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    
    Thanks Falko
     
  13. bschultz

    bschultz Member

    Similar message trying to send from inside my network...

    Oct 5 10:49:22 mail postfix/smtpd[5741]: cannot load Certificate Authority data
    Oct 5 10:49:22 mail postfix/smtpd[5741]: warning: TLS library problem: 5741:error:02001002:system library:fopen:No such file or directory:bss_file.c:122:fopen('/etc/postfix/ssl/cacert.pem','r'):
    Oct 5 10:49:22 mail postfix/smtpd[5741]: warning: TLS library problem: 5741:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:125:
    Oct 5 10:49:22 mail postfix/smtpd[5741]: warning: TLS library problem: 5741:error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib:by_file.c:274:
    Oct 5 10:49:22 mail postfix/smtpd[5741]: connect from unknown[192.168.1.1]
    Oct 5 10:49:22 mail postfix/smtpd[5741]: warning: unknown[192.168.1.1]: SASL LOGIN authentication failed: authentication failure
    Oct 5 10:49:22 mail postfix/smtpd[5741]: lost connection after AUTH from unknown[192.168.1.1]
    Oct 5 10:49:22 mail postfix/smtpd[5741]: disconnect from unknown[192.168.1.1]
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Did you create the certificate as shown in the tutorial? Please re-create it.
     
  15. bschultz

    bschultz Member

    I've recreated the certificate...now here is the error message:

    Code:
    Oct  7 01:46:01 mail courierpop3login: Connection, ip=[::ffff:192.168.1.1]
    Oct  7 01:46:01 mail postfix/smtpd[2771]: connect from unknown[192.168.1.1]
    Oct  7 01:46:01 mail postfix/smtpd[2771]: warning: unknown[192.168.1.1]: SASL LOGIN authentication failed: authentication failure
    Oct  7 01:46:01 mail courierpop3login: Connection, ip=[::ffff:192.168.1.1]
    Oct  7 01:46:01 mail postfix/smtpd[2771]: lost connection after AUTH from unknown[192.168.1.1]
    Oct  7 01:46:01 mail postfix/smtpd[2771]: disconnect from unknown[192.168.1.1]
    
    In the "Perfect Etch Setup" how-to, there is a final main.cf of the postfix config file. In the "Virtual Postfix with MySQL" hhow-to, there isn't one. Can I copy the "perfect" setup config with this configuration of Etch? I just want to make sure that is as it should be.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    No, don't do this. These two setups are not compatible with each other.

    Are you sure that you used the correct username and password?
     
  17. bschultz

    bschultz Member

    I have Outlook setup to use the same login info for sending and receiving, and I am able to receive, so that shouldn't be the problem.
     
  18. faromount

    faromount New Member

    The original question was about not relaying?
    Your mynetwork value is localhost only.
    mynetworks = 127.0.0.0/8

    Have you tried adding in your real IP range eg 192.168.1.0/24 ?
    mynetworks = 127.0.0.0/8, 192.168.1.0/24

    http://www.postfix.org/basic.html#relaying
     
  19. bschultz

    bschultz Member

    Sorry it's been so long since I've had time to work on this...

    This caused postfix to fail...I couldn't even log in on Squirrelmail. I recreated the certs...and now I'm getting a cert error again.

    I don't even have an /etc/postfix/ssl directory. And I'm also still getting the SASL error.

    What should I try?

    Thanks!
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you followed the tutorial to the letter? Because that directory is created during the tutorial.
     

Share This Page