postfix and user

Discussion in 'Installation/Configuration' started by carlainz, May 7, 2006.

  1. carlainz

    carlainz New Member

    what i need to check now ? after 72 hours don't work jet ...

    Thanks:)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Maybe Gmail is caching the DNS records for some time? Your records are ok.
     
  3. carlainz

    carlainz New Member

    Hi now i have try with : hotmail , gmail , yahoo , from my office , tiscali .
    But it's the same , i don't receive nothing , and after some hours the email come back with :

    These recipients of your message have been processed by the mail
    server:
    [email protected]; Failed; 4.4.7 (delivery time expired)

    [email protected]; Failed; 4.4.7 (delivery time expired)

    For check email i use squirrelmail , it's possible is a spamassasin problem ?
    If i send a email from [email protected] to [email protected] arrive in 2 second ....

    In ISpconfig Management-Setting-dns in field default Ns1 i have www.softhelp.it in Ns2 is the same . I need to change in ns1.softhelp.it or mail.softhelp.it or somethings like this ?

    Thanks:)
     
    Last edited: May 15, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Make sure your firewall doesn't block port 25. What's in /etc/postfix/main.cf?
     
  5. carlainz

    carlainz New Member

    Hi

    The port 25 is correctly open in firewall and in router. selinux is disable ...

    Thank you very much for your help

    my main.cf

    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    #mydestination = $myhostname, localhost.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases

    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5

    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.8/samples
    readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    mailbox_command =

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's this?
    Code:
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    Comment it out and restart Postfix.
     
  7. carlainz

    carlainz New Member

  8. falko

    falko Super Moderator ISPConfig Developer

    Ahh, ok, it should be

    Code:
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             xxgdb $daemon_directory/$process_name $process_id & sleep 5
    and not

    Code:
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
     
  9. carlainz

    carlainz New Member

    yes my main.cf it's correct , before was a copy/paste error

    this is my main.cf
     

    Attached Files:

  10. falko

    falko Super Moderator ISPConfig Developer

    Is it working now?
     
  11. carlainz

    carlainz New Member

    no , my main.cf is correct now and also before ...
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Is it working now?
    Make sure your provider doesn't block port 25.
     
  13. carlainz

    carlainz New Member

    NO doesn't work .

    the port 25 work fine ( test with scanport )
    It's possible a Ispconfig Bug ? probabily doesn't work fine in fedora 5 x86_64 ....
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not a mailserver, it is a configuration frontend for mailservers like postfix or sendmail. So if your email wont work and the config files written by ISPConfig are correct, it can not be an ISPConfig bug :)

    A portscan does not say much if your mailserver works. Try to connect with telnet on port 25 to your server.

    telnet www.yourserver.com 25

    After you have established the connection to your postfix mail server type

    ehlo www.yourserver.com

    If you see the lines

    250-STARTTLS

    and

    250-AUTH

    everything is fine.

    Type

    quit
     
  15. carlainz

    carlainz New Member

    Hi from the server i have try to do :

    [[email protected] ~]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 softhelp.it ESMTP Postfix
    ehlo localhost
    250-myserver.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    quit
    221 Bye
    Connection closed by foreign host.
    [[email protected] ~]# telnet myserver.com 25
    Trying 82.x.x.x...
    Connected to myserver.com (82.x.x.x).
    Escape character is '^]'.
    220 myserver.com ESMTP Postfix
    ehlo myserver.com

    421 myserver.com Error: timeout exceeded
    Connection closed by foreign host.



    when i type ehlo softhelp.it i have no answer ...:(

    From a external ws i have try one portscan and port 25 it's open ....
     
    Last edited: May 19, 2006
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have any kind of router or firewall between your server and the internet?
     
  17. carlainz

    carlainz New Member

    yes i have a router , and the port 25 is correctly redirect to the fedora mail server ....
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that you do not block port 25 with your router or linux server firewall. If you use the ISPConfig firewall, make sure you disabled the firewall that comes with your linux distribution as default.
     
  19. carlainz

    carlainz New Member

    where i can check if i use ISPconfig firewall?
    I have try to disable fedora firewall but it's the same ....

    but i think this is not the problem because from the external , with portscan i find port 25 open . If i turn off fedora box , the port 25 is closed ...

    thanks
     
    Last edited: May 20, 2006
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig firewall is configured in ISPConfig under Management > Server > Services.
     

Share This Page