Postfix and Spam !!!

Discussion in 'Installation/Configuration' started by brainz, Nov 28, 2007.

  1. brainz

    brainz Member

    Hi All,

    I just edited the main.cf file for the mail server that i am running and i added this to it....


    Which seems ok and the mail server is running fine...

    However in the mail.log i get a message like this...

    The xxx.xxx.xx.xxx is a ip address i would say form the recipient sending email to the server.

    It seems the incoming ip adress is being added to the spam server for some reason...

    like

    which is not being recognised.

    Please if anyone has a idea....??

    regards
    brainz
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. brainz

    brainz Member

    Hi Falko,

    Im sorry but this was just one example, however it seems all the spam list servers are producing the same message....

    If i take out all of them there i cant see the sense in this type of protection from spam.

    Unfortunantly there all doing the same thing....

    Any help would be apreciated

    regards
    brainz
     
    Last edited: Nov 29, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
     
  5. brainz

    brainz Member

    Hi Falko,

    The /etc/resolv.conf has in it a internal servers ip address that is running a internal domain. It does run dns but only for the local domain.

    but in /etc/resolv.cong its simply nameserver 192.168.0.xxx which is the server inside the local network that runs a local domain.

    regards
    brainz
     
    Last edited: Dec 1, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    Try this resolv.conf instead:
    Code:
    nameserver 145.253.2.75
    nameserver 193.174.32.18
     
  7. brainz

    brainz Member

    Hi Falko,


    i tried these nameservers...

    but this not made a difference...

    i cant even do a simple ping google.com i get this..

    i can ping the default gateway 192.168.0.1 and i can ping our external ip address 60.229.253.45 just find it seems anything beyond i cannot ping anything beyond this...

    any help would be appreciated... Thankyou..

    regards
    brainz
     
    Last edited: Dec 3, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ping -c2 64.233.187.99
    ? (64.233.187.99 is a Google server.)
     
  9. brainz

    brainz Member

    Hi Falko,

    Thankyou for your help...

    I have sorted the issue.... The server is now resolving domains.

    I used the 2 nameservers you provided... Now it is resolving... What i actually did is disonnected the whole network and connected the server directly to the router as the only box on the network and then i changed the nameservers to the ones you provided. Then restarted the server which i did not need to do actually but i did.

    The server started to resolve...

    Thankyou for you help once again.

    regards
    brainz
     

Share This Page