postfix and quota

Discussion in 'HOWTO-Related Questions' started by mikeyr, May 2, 2008.

  1. mikeyr

    mikeyr New Member

    I am going to try and follow this howto "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail for Ubuntu 7.1" but use Ubuntu 8.04 instead.

    My one question is do I still need to patch Postfix for Quota ? I thought I no longer needed to but can't find any reference to it.

    Another side question would be the Perfect Server series for 8.04, do they allow virtual users/domains ? it was not clear to me as it appears to be designed more for a ISP than anything.

    My goal is to set up a small imap mail server for 2 domains (maybe 3 in the near future), 1 with 18 users and the second with 21, would prefer it to be a vmware vmx but I did not see one available for 8.04
     
  2. falko

    falko Super Moderator ISPConfig Developer

    AFAIK you still need to patch Postfix.

    No, these setups are not compatible. The "Perfect Setups" prepare the system for the installation of ISPConfig which creates system users instead of virtual users.
     
  3. mikeyr

    mikeyr New Member

    I am using the Virtual Users and Domains for Ubuntu 7.1 BUT I am using 8.04

    During the postfix quota patch on Ubuntu 8.04 I get the following errors:

    dpkg-checkbuilddeps: Unmet build dependencies: libdb-dev (>= 4.6.19-1)
    dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.

    I had modified the lines above in the howto and changed it from apt-get install libdb4.5-dev apt-get install libdb4.6-dev but I still get that error, is there another package I need to modify also ?
     
  4. mikeyr

    mikeyr New Member

    I ended doing dpkg-buildpackage -d as suggested by the error message to ignore the version mismatch, gave some warnings but seems to have worked.

    Should I have done something else ?
     
    Last edited: May 6, 2008
  5. mikeyr

    mikeyr New Member

    almost there, also could not find dcc-client
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    apt-cache search dcc
    ?
     
  7. mikeyr

    mikeyr New Member

    My first attempt did not work yesterday :( not sure what I did wrong, trying again today. Yesterday I installed on a virtual machine and then copied that virtual machine to a real computer in the evening and I could not get eth0 to be recognized once I moved it, although it worked fine on the computer I installed on. Either way that is NOT related to getting mail to work with virtual users, I was just trying to take a shortcut that failed. Trying again today on the actual computer that will be the server.

    Code:
    [email protected]:/home/mike# apt-cache search dcc
    konversation - user friendly Internet Relay Chat (IRC) client for KDE
    fglrx-amdcccle - Dummy package for easy transition
    autobook - GNU Autoconf, Automake and Libtool Book
    caspar - Makefile snippets for common tasks
    ddccontrol - a program to control monitor parameters
    ddccontrol-db - monitor database for ddccontrol
    gddccontrol - a program to control monitor parameters
    iroffer - IRC file distribution bot
    kvirc - KDE based next generation IRC client with module support
    kvirc2 - Fully scriptable graphical IRC client with plugin support
    ladcca-bin - LADCCA example clients
    ladcca-dev - Development files for LADCCA
    ladcca2 - LADCCA shared library files
    ladccad - LADCCA server
    libddccontrol-dev - development library for ddccontrol
    libddccontrol0 - shared library for ddccontrol
    libmarc-crosswalk-dublincore-perl - Convert data between MARC and Dublin Core
    liece-dcc - DCC program for liece
    lostirc - simple IRC client for X11
    python-irclib - IRC client library for Python
    sirc - The full-featured Perl IRC client
    synce-dccm - Daemon to keep a connection to your WinCE device up
    systraq - monitor your system and warn when system files change
    uruk - Very small firewall script, for configuring iptables
    xchat - IRC client for X similar to AmIRC
    znc - an advanced IRC bouncer
    sdcc - Small Device C Compiler
    sdcc-doc - Small Device C Compiler (documentation)
    sdcc-libraries - Small Device C Compiler (libraries)
    sdcc-ucsim - Micro-controller simulator for SDCC
    [email protected]:/home/mike#
    
     
    Last edited: May 6, 2008
  8. mikeyr

    mikeyr New Member

    really close :)

    I can send mail to the user/domain and I can get the mail, I can see in /home/vmail that the mail got sent. But when I try to SEND mail using the server it fails to log in.

    /var/log/mail.log shows

    Date/time mailer postfix/smtpd warning : SASL Auth failure cannot connect to saslauthd server: permission denied.
    Date/time mailer postfix/smtpd SASL PLAIN authentication failed: generic failure
     
    Last edited: May 6, 2008
  9. mikeyr

    mikeyr New Member

    Well I surrender...I am going to downgrade to ubuntu 7.1 and see if I can get this to work, I spent hours surfing the web and verifying everything I could think of and things I never heard of even and I still can't send mail. I even re-installed from scratch the entire thing in case I missed a step in the howto.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    Code:
    adduser postfix sasl
    /etc/init.d/postfix restart
     
  11. mikeyr

    mikeyr New Member

    I had found that in another post here and tried it, did not seem to make a difference :(
     

Share This Page