postfix and dovecot not happy together

Discussion in 'Installation/Configuration' started by bigmatlem, Sep 1, 2010.

  1. bigmatlem

    bigmatlem New Member

    I have a problem with users logging in to their e-mail accounts. I have even tried the telnet to the pop and imap server. It appears that dovecot doesn't know where to look for the user files.

    Is ispconfig 3 storing these files in a mysql database and if so how do I get dovecot to point to that db so that it will work properly?

  2. Ghostdare

    Ghostdare Member

    Any errors in mail log
  3. bigmatlem

    bigmatlem New Member

    no error messages

    There are no error messages in the logs. However it appears that ISP config when it installed did not configure dovecot. So I looked in the other systems I have and looked in the .conf files and found that that it tried to configure courier which I could never get to work.

    So I found the problem but need the solution to get ispconfig/dovecot to talk to the database to get it working. I can't find the fields its looking for for authentication to put it into the dovecot-mysql info.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no need to edit a config file manually, tthe files are created and edited by the ispconfig installer. If a e.g. dovecot update has overwitten a config file or you installed dovecot after ispconfig was installed, then download the ispconfig tar.gz again, run the update.php script and choose to reconfigure services during update.
  5. bjoern

    bjoern New Member

    I got similar problems; after installing ispconfig3 on 3 servers (web, mail, db) almost everything worked fine, but I am having trouble getting the mailservers running.

    The logs show, that I am able to receive mails, but the server itself rejects them:

    Same problem trying to check mails:
    mail.err and mail.warn are empty :-(
    Last edited: Sep 7, 2010
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Which tutorial did you use to install the server?
  7. bjoern

    bjoern New Member

    Installing A Multiserver Setup With Dedicated Web, Email, DNS And MySQL Database Servers On Debian 5.0 With ISPConfig 3
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Might be a problem with replication. Take a look in the ispconfig mysql database of the slave server that runs the mail system and check if the domain is listed in the mail_domain table there and if a mailbox with the email address of this recipient is also listed in the database.
  9. bjoern

    bjoern New Member

    you were right, thx!

    after deleting the domains and readding them the appear now in all databases.

Share This Page