Postfix and Dkim

Discussion in 'Server Operation' started by joemiller, Oct 31, 2012.

  1. joemiller

    joemiller New Member

    Postfix and Dkim: Solved

    Hi, I'm running a Centos 6.3 and ispconfig 3 mailserver. I've installed postfix, dovecot and squirrelmail, which are all running fine. I'm trying to get opendkim working with postfix. I have got openskim to generate a dkim signature, which is added to outgoing emails, and also added the corresponding dns entry to match it.
    However, when I check the dkim entries with is says:
    result = fail
    Details: bad RSA signature
    This is confirmed by sending emails through my hotmail account, and looking at the source. A quick check here shows that the public and private keys are correct, but they're not getting matched for the message. I'm assuming that the message is getting altered by some process after the dkim header has been added, but I'm at a loss to work out where that's happening, and what to do about it.
    Can anyone here shed any light on this problem?
    Many thanks.
    Last edited: Nov 1, 2012
  2. joemiller

    joemiller New Member

    Problem solved. I was sending blank emails to the verifiers, and, I presume, postfix was adding something in the body. If I send a filled-out email, then they all pass. Also had a problem with the incorrect system time generating errors, which I've now fixed by synchronising the system time.

    thanks for looking at my post.

Share This Page