Postfix and 550 Reverse DNS lookup failed for host error

Discussion in 'Server Operation' started by rasjavita, Nov 18, 2008.

  1. rasjavita

    rasjavita New Member

    Hi all.

    The problem is with mail accounts of an ISP (wanadoo).

    When i send mail to any email address from wanadoo,orange,etc (all are the same ISP) the mails are returned with this error in my logs:

    server refused to talk to me: 550 Reverse DNS lookup failed for host XX.XXX. (port 25)

    I don't know if I have more problems, but I need to resolv this first. The IP address of my server is incomplete only the first and second octets appear.

    I think the mails are retuned because the other server receive an incomplete IP from my server.

    I try several combinations with "mynetwoks and mynetworks_style" in Postfix but nothing changes.

    Any idea.

    Thanks.
     
    Last edited: Nov 18, 2008
  2. marpada

    marpada New Member

    Last edited: May 13, 2011
  3. rasjavita

    rasjavita New Member

    I made the test at http://www.ipchecking.com/.

    General information on XX.XXX.XX.XX:

    IP address: XX.XXX.XX.XX
    Host name: cliente-XXXXX.iberbanda.es (This is my ISP's name)
    Country: SPAIN SPAIN Flag

    RBL (Real-Time Blocking List) lookup on XX.XXX.XX.XX:
    SPAMCOP - (SpamCop Blocking List): Not Found
    SBL (Spamhaus Block List): Not Found
    XBL (Spamhaus eXploits Block List"): Not Found
    DSBL (Distributed Server Boycott List): Not Found
    CBL (Composite Blocking List): Not Found
    NJABL (Not Just Another Blocklist): Not Found
    SORBS (Spam and Open-Relay Blocking System): Not Found
    SURBL: Not Found

    The IP address is well in all tests. The PTR record points to my isp anyway the problem is why an incomplete ip address appear in my mail logs in the followin form XX.XXX. look, only the first and second octets.

    Thanks.
     

Share This Page