Postfix amavis et al Howto ... no spamassassin upon upgrade

Discussion in 'HOWTO-Related Questions' started by jon, Jan 26, 2007.

  1. jon

    jon Member HowtoForge Supporter

    I had the Postfix amavis howto working just nicely. However an upgrade to either backports packages, or etch seems to almost break spamassassin. The log ends up with something like this ...

    Jan 26 13:25:26 oliver2 amavis[21029]: (21029-01) Passed CLEAN, [xx.xxx.xxx.13] [xxx.xx.xx.38] <CENSORED> -> <CENSORED>, Message-ID: <[email protected]>, mail_id: NJgLD4hdLmxM, Hits: -, queued_as: BC69C4A08F, 216 ms

    No ryzor pyzor or friends seem to be going either. I'm not really sure where to start on this one.

    ** EDIT **

    http://www.howtoforge.com/forums/showthread.php?t=5046

    That seems to start me onto the right track. Spamassassin is now reporting actual hits.

    I should note that if anyone isn't into futzing with the existing config vs. Falko's config, you can simply paste the entire thing into

    /etc/amavis/conf.d/15-content_filter_mode which begins with the line "Place your configuration directives here. They will override those in earlier files."

    This would suggest that you can simply throw Falko's config in there, and any settings in there will override the existing settings in the other config files in that dir. This is also recommended, so that apt doesn't paste over your custom config upon upgrade.

    Hope that helps someone ...



    ** EDIT **

    I haven't noticed razor working, but have seen pyzor working. Also I don't see those neat little percentages in the logs that I believe were from razor. Any help?
     
    Last edited: Jan 27, 2007

Share This Page