Postfix + Altermime on FC6 Not working

Discussion in 'HOWTO-Related Questions' started by simjith, Oct 11, 2008.

  1. simjith

    simjith New Member

    Hi All,


    I am trying to add Disclaimer to all outgoing mails

    My MTA is Postfix 2.4.5
    OS Fedora Core 6
    I had followed the instructions provided in this URL

    http://www.howtoforge.com/add-autom...utgoing-emails-with-altermime-postfix-fedora8

    Also googled and tried lots of other links too
    but what ever URL had i tried
    its showing a common error while sending mails
    First of all the mail is not at all delivering

    And always showing below error message in /etc/log/maillog
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Oct 11 11:35:19 it001 postfix/qmgr[3767]: 5EA8650056: from=<[email protected]>, size=546, nrcpt=1 (queue active)
    Oct 11 11:35:19 it001 pipe[3844]: fatal: pipe_command: execvp /etc/postfix/disclaimer: Permission denied
    Oct 11 11:35:19 it001 postfix/pipe[3843]: 5EA8650056: to=<[email protected]>, relay=dfilt, delay=1244, delays=1244/0.01/0/0.18, dsn=4.3.0, status=deferred (temporary failure. Command output: pipe: fatal: pipe_command: execvp /etc/postfix/disclaimer: Permission denied )/etc/postfix/disclaimer
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    I had tried chmod 777 /etc/postfix/disclaimer
    chown nobody /var/spool/filter
    chown nobody:mail /etc/postfix/disclaimer
    etc


    Does anyone have a clue?

    Thanks in advance,

    Simjith
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/postfix/
    ?
     

Share This Page