postfix 554 Relay access denied

Discussion in 'Server Operation' started by ratcateme, May 28, 2008.

  1. ratcateme

    ratcateme New Member

    i am trying to setup postfix on a server at my house it uses dyndns.com for a dynmaic IP and i am access it from a pc on my local network usin a local network IP if that makes any difference.
    When i try to send an email from outlook i got this output form wireshark
    Code:
    220 domain.homelinux.com ESMTP Postfix
    EHLO BOBDESK
    250-domain.homelinux.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    MAIL FROM: <scott@domain.homelinux.com>
    250 2.1.0 Ok
    RCPT TO: <test@gmail.com>
    554 5.7.1 <test@gmail.com>: Relay access denied
    QUIT
    221 2.0.0 Bye
    this is my postfix config from /etc/postfix/main.cf
    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    myhostname = domain.homelinux.com
    mydomain = domain.homelinux.com
    inet_interfaces = all
    mydestination = $myhostname, localhost.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    relay_domains = $mydestination
    relayhost = smtp.isp.co.nz
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mail_spool_directory = /var/mail
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    myhostname = domain.homelinux.com
    
    and here is the line from /var/log/maillog
    Code:
    May 29 07:29:06 ratcat postfix/smtpd[2806]: NOQUEUE: reject: RCPT from unknown[10.1.1.3]: 554 5.7.1 <test@gmail.com>: Relay access denied; from=<scott@domain.homelinux.com> to=<test@gmail.com> proto=ESMTP helo=<BOBDESK>
    BOBDESK and 10.1.1.3 are the name and ip of the pc i was using to send the email from.

    Scott.
     
  2. falko

    falko Super Moderator

    Did you enable "Server requires authentication" in your email client?
     

Share This Page