postfix: 550 Recipient address rejected

Discussion in 'HOWTO-Related Questions' started by fork, Nov 8, 2007.

  1. fork

    fork New Member

    This is the log of the error
    Code:
    Nov  8 16:33:51 skyglow postfix/smtpd[6503]: connect from localhost[127.0.0.1]
    Nov  8 16:33:51 skyglow postfix/smtpd[6503]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail.mailserver.org>
    Nov  8 16:33:51 skyglow postfix/smtpd[6503]: lost connection after RCPT from localhost[127.0.0.1]
    i followed falko's great howto.
    My system works slightly differernt because of my needs.
    Postfix uses mysql to read recipient table, tls is enabled on postfix.

    Usual receiving mail works perfectly. I can send mail from outside to this box, and i can send from localhost to localhost. How you can read from the log i'm sending a mail from localhost to a foreign host and it fails.

    this are possible interesting variable in my main.cf
    Code:
    mynetworks = 127.0.0.0/8
    mydestination = localhost
    
    virtual_mailbox_base = /home/vmail
    virtual_mailbox_domains = mysql:/etc/postfix/mysql_domains.cf
    virtual_alias_maps = mysql:/etc/postfix/mysql_alias.cf
    virtual_mailbox_maps = mysql:/etc/postfix/mysql_mailbox.cf
    virtual_transport = virtual
    mydomain = mailserver.org
    myhostname = mail.mailserver.org
    
    virtual_minimum_uid = 150
    virtual_uid_maps = static:150
    virtual_gid_maps = static:150
    virtual_mailbox_limit = 100000000
    virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql_quota.cf
    virtual_mailbox_limit_inbox = no
    virtual_mailbox_limit_override = yes
    virtual_maildir_extended = yes
    virtual_overquota_bounce = no
    virtual_maildir_limit_message = "User's quota reached!"
    #virtual_maildir_limit_message_maps = hash:/etc/postfix/vmsg
    virtual_trash_count = yes
    #virtual_trash_name = ".Trash"
    virtual_maildir_filter = no
    #virtual_maildir_filter_maps = hash:/etc/postfix/vfilter
    
    Software versions are:
    postfix 2.4.6 (patched with vda)
    mysql 5.0.1

    P.S.
    of course domains and other are not real
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. fork

    fork New Member

    [email protected] is on another provider.
    mhm alot i'd say^^ your one too.
    because i needed to integrate
    postfix mysql(for virtual mailboxes) dovecot, and all pkgs including ssl.
    it's all working except the sending to other provider, even if the sender is localhost.

    i didn't follow completely your tutorial because i wanted to recompile the whole system.
    Postfix patched before make and then:
    make makefiles CCARGS="-DHAS_MYSQL -DUSE_TLS -I/usr/local/mysql/include/mysql -I/usr/local/ssl/include" AUXLIBS="-L/usr/local/mysql/lib/mysql -L/usr/local/ssl/lib -lmysqlclient -lz -lm -lssl -lcrypto"


    List of tutorials
    http://yocum.org/faqs/postfix-tls-sasl.html
    http://genova.isf-italia.org/linux-e-isf/postfix-dovecot-mysql
    http://www.delouw.ch/linux/Postfix-Cyrus-Web-cyradm-HOWTO/html/index.html
    http://www.nomoa.com/bsd/postfixadmin.htm
    http://www.phparchitecture.com/howto_show.php?id=2
    http://gentoo-wiki.com/HOWTO_Email_Virtual_Server_Maildrop_and_Spam_Assasin
    http://sylvestre.ledru.info/howto/howto_qmail_vpopmail.php
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. fork

    fork New Member

    is there a way to let postfix deliver mail to other providers. without them beeing in a list, and only from localhost?
    i just wanna postfix sends mail if webmail asks it^^

    mynetworks = 127.0.0.0/8
    shouldn't do it? or since it's virtual delivering enabled it doesn't work?
     
    Last edited: Nov 10, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    If you want to connect to Postfix only from localhost, use
    Code:
    inet_interfaces = 127.0.0.1
    in /etc/postfix/main.cf and restart Postfix.
     
  7. fork

    fork New Member

    briefly.. what i wanna is^^
    accept every mail that has to be delivered to my pc.
    accept mail from localhost to everything else.
    deny all other (relay and so..)
    how it's the configuration atm doesn't work oO it always did with
    mynetworks = 127.0.0.0/8 i think maybe i made somewhere else a mistake
     
  8. falko

    falko Super Moderator ISPConfig Developer

    In this case
    Code:
    mynetworks = 127.0.0.0/8
    is the right setting.
     
  9. fork

    fork New Member

    i opened the topic because i already seted various things like taht in mynetwork.
    i still get this as error
    550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table
    can it be that because i patched postfix with vda i get this "error"?
     
  10. falko

    falko Super Moderator ISPConfig Developer

  11. fork

    fork New Member

    it's on a remote
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Then take a look at post #4.
     
  13. fork

    fork New Member

    if for remote = destmail.inc
    and for local = 127.0.0.1

    it exists because it's my address i registered on this forum.
    i tryed to send mail by telnet and i get the same error message in the console.
    postfix just don't allow me to send mail from 127.0.0.1 to other server if it's not in the virtual address table. i don't understand why mynetworks option should work to fix this but doesn't. should this be a bug?
     
  14. fork

    fork New Member

    thanks for all you answers. i got a mail after subscribing to vda newsletter saying that there were 2 bugs in their release. so i solved my problem
     

Share This Page