posfix error

Discussion in 'Installation/Configuration' started by fisherofer, Jul 9, 2011.

  1. fisherofer

    fisherofer New Member

    i have contes 5.6 and latest version of ispconfig
    my server can send email

    [main.cf]
    relayhost = localhost
    smtp_sasl_auth_enable = no
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    mailbox_size_limit = 0
    message_size_limit = 0



    [root@mail postfix]# tail /var/log/maillog
    2011-07-09T01:27:45.367661+03:00 mail postfix/master[11546]: daemon started -- version 2.3.3, configuration /etc/postfix
    2011-07-09T01:29:31.083015+03:00 mail sendmail[11659]: p68MTUfQ011659: from=apache, size=553, class=0, nrcpts=1, msgid=<[email protected]>, relay=apache@localhost
    2011-07-09T01:29:31.098413+03:00 mail postfix/smtpd[11660]: connect from localhost.localdomain[127.0.0.1]
    2011-07-09T01:29:31.098435+03:00 mail postfix/smtpd[11660]: 17DDFFF113: client=localhost.localdomain[127.0.0.1]
    2011-07-09T01:29:31.344519+03:00 mail postfix/cleanup[11663]: 17DDFFF113: message-id=<[email protected]>
    2011-07-09T01:29:31.352609+03:00 mail sendmail[11659]: p68MTUfQ011659: to=[email protected], ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=30553, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 17DDFFF113)
    2011-07-09T01:29:31.352636+03:00 mail postfix/qmgr[11548]: 17DDFFF113: from=<[email protected]>, size=869, nrcpt=1 (queue active)
    2011-07-09T01:29:31.371861+03:00 mail postfix/smtpd[11660]: disconnect from localhost.localdomain[127.0.0.1]
    2011-07-09T01:29:31.432680+03:00 mail postfix/smtp[11664]: warning: relayhost configuration problem
    2011-07-09T01:29:31.435735+03:00 mail postfix/smtp[11664]: 17DDFFF113: to=<[email protected]>, relay=none, delay=0.33, delays=0.25/0/0.08/0, dsn=4.3.5, status=deferred (Host or domain name not found. Name service error for name=localhost type=A: Host not found)

    [root@mail postfix]# ping localhost
    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.017 ms
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.017 ms
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=3 ttl=64 time=0.025 ms
    c64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=4 ttl=64 time=0.027 ms


    Please help me to know why my server dont send email
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?
     
  3. fisherofer

    fisherofer New Member

    i have connection with ssh to my sever

    DEVICE=eth0
    BOOTPROTO=none
    ONBOOT=yes
    HWADDR=00:50:56:a3:02:3e
    NETMASK=255.255.255.192
    IPADDR=XXX
    GATEWAY=XXXX
    TYPE=Ethernet
    USERCTL=no
    IPV6INIT=no
    PEERDNS=yes
    DNS1=8.8.8.8
    DNS2=8.8.4.4

    my hosts file

    # Do not remove the following line, or various programs
    that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
     
  4. fisherofer

    fisherofer New Member

    [main.cf]
    #relayhost = localhost
    smtp_sasl_auth_enable = no
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    mailbox_size_limit = 0
    message_size_limit = 0

    and its working now
     

Share This Page