Ports problem with phpmyadmin and squirrelmail

Discussion in 'Installation/Configuration' started by joemiller, Oct 12, 2012.

  1. joemiller

    joemiller New Member

    Hi, I've managed to install ISPConfig 3.0.4.6 on Centos 6.3, running nginx.
    Everything runs smoothly, so far, thanks to Falko and his precise tutorials :)

    One small problem is when I try to access phpmyadmin, and squirrelmail, from the ISPConfig control panel, it directs me to the wrong ports.
    e.g.
    Click on the database in the control panel, and it send me to
    https://mysite.co.uk:8080/phpmyadmin, which returns a 404 page not found error. If I manually change the url to
    http://mysite.co.uk.co.uk:8081/phpmyadmin then I get the phpmyadmin login page.
    In the manual it says that phpmyadmin listens on port 8081, so I don't understand why ISPConfig is directing me to port 8080.

    I'm also not sure why my ssl isn't working; I've got the following in my nginx directives for the site;
    location /phpmyadmin {
    root /usr/share/;
    index index.php index.html index.htm;
    location ~ $host:8081/phpmyadmin/(.+\.php)$ {
    try_files $uri =404;
    root /usr/share/;
    fastcgi_pass 127.0.0.1:9000;
    fastcgi_param HTTPS on; # <-- add this line
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $request_filename;
    include /etc/nginx/fastcgi_params;
    fastcgi_param PATH_INFO $fastcgi_script_name;
    fastcgi_buffer_size 128k;
    fastcgi_buffers 256 4k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_temp_file_write_size 256k;
    fastcgi_intercept_errors on;
    }
    location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
    root /usr/share/;
    }
    }
    location /phpMyAdmin {
    rewrite ^/* /phpmyadmin last;
    }
    location /squirrelmail {
    root /usr/share/;
    index index.php index.html index.htm;
    location ~ ^/squirrelmail/(.+\.php)$ {
    try_files $uri =404;
    root /usr/share/;
    fastcgi_pass 127.0.0.1:9000;
    fastcgi_param HTTPS on; # <-- add this line
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $request_filename;
    include /etc/nginx/fastcgi_params;
    fastcgi_param PATH_INFO $fastcgi_script_name;
    fastcgi_buffer_size 128k;
    fastcgi_buffers 256 4k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_temp_file_write_size 256k;
    fastcgi_intercept_errors on;
    }
    location ~* ^/squirrelmail/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
    root /usr/share/;
    }
    }
    location /webmail {
    rewrite ^/* /squirrelmail last;
    }
    According to the setup instructions, this should allow me to use https on both phpmyadmin and squirrelmail.

    I have very similar problems with squirrelmail. Can anyone advise me please?
    Many thanks.
     
  2. falko

    falko Super Moderator

    You must set the correct phpMyAdmin URL in the system settings in ISPConfig (Interface Config, I think).

    The apps vhost doesn't use SSL. You'd have to configure it manually to do so.
     
  3. joemiller

    joemiller New Member

    Ok, thanks I'll add it to my to-do list.
     

Share This Page