Port change from 81 to 80

Discussion in 'Installation/Configuration' started by bzzik, Dec 12, 2008.

  1. bzzik

    bzzik New Member

    Hey guys!

    Is it possible to change access port from 81 to 80?
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. bzzik

    bzzik New Member

    Thanks, I will try!
     
  4. bzzik

    bzzik New Member

    I read everything, but do not understand where to insert this:

    Code:
    NameVirtualHost *
    <VirtualHost *>
            ServerName ispconfig.example.com
            DocumentRoot /var/www/
            ProxyRequests Off
    
            <Proxy *>
              Order deny,allow
              Allow from all
            </Proxy>
    
            ProxyPass / http://ispconfig.example.com:81/
            ProxyPassReverse / http://ispconfig.example.com:81/
    </VirtualHost>
    Cause in httpd.conf I cannot find
    Code:
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using? The tutorial was written for Debian/Ubuntu.
     
  6. bzzik

    bzzik New Member

    I am using Centos 5.2 (perfect server install)
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Ok, then you Apache configuration is a bit different. You must add that part before any vhosts are defined.
     
  8. bzzik

    bzzik New Member

    Ok, I added it here:

    Code:
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for requests without a known
    # server name.
    #
    #<VirtualHost *:80>
    #    ServerAdmin [email protected]
    #    DocumentRoot /www/docs/dummy-host.example.com
    #    ServerName dummy-host.example.com
    #    ErrorLog logs/dummy-host.example.com-error_log
    #    CustomLog logs/dummy-host.example.com-access_log common
    #</VirtualHost>
    
    NameVirtualHost *
    <VirtualHost *>
        ServerName my.example.com
        DocumentRoot /home/
        ProxyRequests Off
    
        <Proxy *>
            Order deny,allow
            Allow from all
        </Proxy>
    
        ProxyPass / http://my.example.com:81/
        ProxyPassReverse / http://my.example.com:81/
    </VirtualHost>
    
    <Directory /home/sharedip>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    
    <Directory /home/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    Than after httpd restart I have error:

     
  9. falko

    falko Super Moderator ISPConfig Developer

    That happens because you have multiple IP addresses, and some of your IPs don'T have any vhosts. You can either change the
    Code:
    NameVirtualHost *
    line or ignore this because it's just a warning and nothing to worry about.
     
  10. bzzik

    bzzik New Member

    Still have no luck... Did everything, but cannot access on port 80. When I load my.example.com I get standard shred IP notice, not admin login:

     
  11. falko

    falko Super Moderator ISPConfig Developer

    And you are using my.example.com in the address bar, not the IP address?
    Are there any errors in Apache's error log?
     
  12. bzzik

    bzzik New Member

    Yes, I am using real domain name, not IP address. And there are errors in Apache log. These errors shows up when I change config.inc.php as described in article. Here are errors:
    P.S.
    Interesting to notice, that error
    shows up every time I restart apache. Even if I use default httpd.conf
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

  14. bzzik

    bzzik New Member

    Thanks. But I want to clear out - to which website root I should install PEAR? To /home/ (as it is my Document Root in ISPconfig) ?

    And is it normal, that my system uses suEXEC (I have no idea what it is :D)? Cause I did not remember during installation that I enabled it :)
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    That depends on your setup. The websites is normally located in /var/www/www.domain.com/web/

    SuEXEC is a part of every apache installation. For details, see apache documentation.
     
  16. bzzik

    bzzik New Member

    I mean I should install it for ISPConfig or for all sites?
     
  17. bzzik

    bzzik New Member

    Still no luck :(

     

Share This Page