Port 25 work around

Discussion in 'Server Operation' started by kwickcut, Jun 28, 2010.

  1. kwickcut

    kwickcut Member

    hello all i have Ubuntu 9.10 running Postfix version 2.6.5 now 2 days ago my isp turned off port 25 for smtp.. is there a good workaround for this? if so please help me out i have 1500 emails waiting to go out. i have been getting away with port 25 being open for sometime now i have comcast and from what i have read they shut that port down some time ago but mine was open till now... i really dont know that much about the mail end so any help would be great thanks

  2. Mark_NL

    Mark_NL New Member

    They closed it down, so you have to use theire smtp servers, to avoid ppl having infected computers which spam random smtp servers. So just use theire smtp servers to send out your mail.
  3. KZeeSoft

    KZeeSoft New Member

    I have experienced the same issue! I have a good amount of emails waiting to go out on my end as well, because my ISP shut down port 25 recently. The thing that really had me stuck (and bugs me!) is that they shut off the port just as I was changing server hardware, so I was thinking all along that I was the source of the error, and it costs me weeks of headaches and failed attempts to fix a problem that did not exist!

    After discussing the issue with them, they told me I would have to purchase some upgraded business class service which will cost me more than I can afford right now =(

    They tried to tell me to "use port 587" to send mail, but after a few weeks of painful troubleshooting and failed attempts, I realize this is not how server->server communication for mail is handled. Port 587 is only for the local side, or clients. Port 25 is still how servers talk to each other and send mail, so this "fix" does not work for people who were running their own mailservers (like myself) The reason they turned off port 25 is so we can't be our own mailservers and potentially become the source of spam.

    Do yourself a favor - don't bother trying to change it, but ask your ISP if they can upgrade you to a business class internet (with static IP) which will then open port 25 again. This seems to be the only viable option, and I have to wait for some funds before I make that jump myself!

    I feel your pain, and I hope this saves you some time =-)

    The community here at Howtoforge was very helpful troubleshooting this issue with me, and I am eternally grateful for their constant help. Even the gurus here can't make an ISP open a port though!
  4. kwickcut

    kwickcut Member

    ok i have found a small workaround using port 2525, 23, 26 by using a smtp service now they have a program you can download that will check the posts they use to see if you can send an email through there service. my problem now is i can send email through them on port 2525 but the mail server is not sending them out i am stuck. this is what i have done

    Move to your Postfix configuration directory (typically /etc/postfix)
    cd /etc/postfix
    Backup your configuration files:
    cp /etc/postfix/* /POSTFIX_BACKUP
    Add the following lines to the bottom of the file if not listed in confg file

    vi /etc/postfix/main.cf
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_mechanism_filter = plain
    relayhost = mail.XXXXXXXX.com:2525
    then set up use rname and password

    vi /etc/postfix/sasl_passwd
    mail.XXXXXXXX.com user name:password
    run encrip code
    postmap hash:/etc/postfix/sasl_passwd
    now restart postfix
    /etc/init.d/postfix restart

Share This Page