Port 25 blocked by ISP

Discussion in 'General' started by ikrudolf, Feb 18, 2013.

  1. ikrudolf

    ikrudolf Member

    My ISP blocks port 25.
    What's the best way to get around this?
  2. edge

    edge Active Member Moderator

  3. ikrudolf

    ikrudolf Member

    So the only thing I have to do is

    and restart Postfix?

    How should I test it?
  4. edge

    edge Active Member Moderator

    if you are not using a firewall than that is all you will need to do on the server.

    Make sure that you setup the client to use the SMTP port 587 instead of port 25
  5. ikrudolf

    ikrudolf Member

  6. ikrudolf

    ikrudolf Member

    It looks like mail is sent but it's not arrived in the mailbox?
  7. ikrudolf

    ikrudolf Member

    Are there any things I can check, config or test?
  8. ikrudolf

    ikrudolf Member

    Changed Squirrelmail
    to use smtp port 587 but still messages don't arrive to destination.
  9. falko

    falko Super Moderator ISPConfig Developer

    Did you configure an email account in ISPConfig?

    What's in /etc/postfix/master.cf? What's the output of
    netstat -tap
  10. ikrudolf

    ikrudolf Member

    I'm trying to use smtp2go and critsend as relay smtp service.

    The servers queue is very full and a lot of mail get's send. But the biggest problem that a lot of mails get bounced (and the services disable my account)

    What can I do about this?
  11. Quijote Shin

    Quijote Shin New Member

    do this
    i guess its a smtp /smtpd problema. you may relay only inside? try first send a local mail.

    in case you use postfix, can you post the config from
    /etc/postfix/main.cnf ?

    1 ## Try send a mail via command line.. this will show up error messages if any

    sh# telnet <yourlocaldomain> <port>
    EHLO <yourlocaldomain>
    mail from: user@<yourlocaldomain>
    rcpto to: <destinationmail>
    Subject: test1

    tata desting



    2 #### post some log files
    tail -f /var/log/mail.err
  12. ikrudolf

    ikrudolf Member

    I can send mail from command line, all mails arrive. My port 25 isn't blocked anymore but the issue with sending mail still is there.

    When I send mail to [email protected] I have a forward in ispconfig it should forward it to my gmail [email protected]

    It looks like it has been send but doesn't arrive in my mail box. When I send mail to [email protected] from command line it arrives in my mail box.

    No error when I send mail to [email protected] in /var/log/mail.err
  13. ikrudolf

    ikrudolf Member

    My main.cf


Share This Page