Poroblem after installing suphp

Discussion in 'Installation/Configuration' started by kyriakos, Sep 20, 2008.

  1. kyriakos

    kyriakos New Member

    I m using fedora 8 and everything was fine until I install suphp.
    I follow the instructions at http://www.howtoforge.com/install-suphp-on-various-linux-distributions-for-use-with-ispconfig-2.2.20-and-above
    I replace $go_info["server"]["apache2_php"] = 'both'; with $go_info["server"]["apache2_php"] = 'suphp'; in /home/admispconfig/ispconfig/lib/config.inc.php
    I run httpd -t with no errors
    I create a new website an I upload an index.php file
    When I visit this site is asking me to download T32x9YEV file


    part of my Vhosts_ispconfig.conf
     
    Last edited: Sep 20, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You must edit the site settings in ispconfig. e.g change the quota and click on save.
     
  3. kyriakos

    kyriakos New Member

    I already did that for all sites. Vhosts_ispconfig.conf is rewritten but sites cant display php

    Thantks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Then most likely mod_suphp is not loaded into your apache or the php cgi binary is not installed.
     
  5. kyriakos

    kyriakos New Member

    php-cli is installed and mod_suphp is loaded.
    I reinstall php-cli and httpd-devel.
    I also install mod_suphp 6.3 from rpm.
    The same problem...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    An the vhost in the file Vhost_ispconfig.conf contains the suphp directives now and not the ones you posted above?
     
  7. kyriakos

    kyriakos New Member

    The vhost is the same:
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.1.100:80
    <VirtualHost 192.168.1.100:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
      </IfModule>
    </VirtualHost>
    NameVirtualHost **.**.***.***:80
    <VirtualHost **.**.***.***:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
      </IfModule>
    </VirtualHost>
    NameVirtualHost **.***.***.***:80
    <VirtualHost **.***.***.***:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
      </IfModule>
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.*******.gr:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.100:80>
    ServerName www.*******.gr:80
    ServerAdmin webmaster@*******.gr
    DocumentRoot /home/www/web1/web
    ServerAlias *******.gr
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /home/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/home/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
      RewriteRule .* - [F]
    </IfModule>
    </VirtualHost>
    #
    #
    #
    
    I also try to change handlers in /etc/suphp.con
    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp.log
    
    ;Loglevel
    loglevel=warn
    
    ;User Apache is running as
    webserver_user=apache
    
    ;Path all scripts have to be in
    docroot=/
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=true
    allow_file_others_writeable=false
    allow_directory_group_writeable=true
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    [handlers]
    ;Handler for php-scripts
    ;php5-script=php:/usr/bin/php-cgi
    x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper
    
    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self
    
    I also try with these last three lines in /etc/httpd/conf.d/mod_suphp.conf
    Code:
    LoadModule suphp_module modules/mod_suphp.so
    suPHP_AddHandler php5-script
    suPHP_Engine on
    suPHP_ConfigPath /etc
    
    Thanks
     
  8. Gimly

    Gimly Member

    Hi All,

    I've the same problem with my websites not with all php website. I deactivate and reactivate php on site setting, but the problem persist.

    php5-cgi are installed, suphp is ok in /home/admispconfig/ispconfig/lib/config.inc.php and Vhosts_ispconfig.conf.

    httpd -t have correct syntax.

    mod_php5 is disabled, I just want to use suphp.

    If you have an idea ?

    Thank you :)

    config : Debian Etch updated with apache 2.2 and php5, ISPConfig 2.2.27, suphp 0.6.3
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page