Pop3/webmail login problem

Discussion in 'Installation/Configuration' started by jake, Oct 19, 2006.

  1. jake

    jake New Member

    Hi,

    I know, there're many threads covering this issue but none of it seem to help me out. The problem is that i can't login into the pop3 server.

    Here's more details:
    -The pop3 server is running (check via various site)
    -I can connect with telnet to the pop3 on port 110
    -I can't login on telnet using either webx_xxx or [email protected] logins (results in error: login failed)
    -The user account is there in /etc/shadow and /etc/passwd
    -I send a mail and it's in the user maildir.
    -My authdaemonrc is set to: modulelist="authuserdb authpam" (setting it only to authpam doesn't work either):
    Code:
    ##VERSION: $Id: authdaemonrc.in,v 1.8 2001/10/07 02:16:22 mrsam Exp $
    #
    # Copyright 2000-2001 Double Precision, Inc.  See COPYING for
    # distribution information.
    #
    # authdaemonrc created from authdaemonrc.dist by sysconftool
    #
    # Do not alter lines that begin with ##, they are used when upgrading
    # this configuration.
    #
    # This file configures authdaemond, the resident authentication daemon.
    #
    # Comments in this file are ignored.  Although this file is intended to
    # be sourced as a shell script, authdaemond parses it manually, so
    # the acceptable syntax is a bit limited.  Multiline variable contents,
    # with the \ continuation character, are not allowed.  Everything must
    # fit on one line.  Do not use any additional whitespace for indentation,
    # or anything else.
    
    ##NAME: authmodulelist:0
    #
    # The authentication modules that are linked into authdaemond.  The
    # default list is installed.  You may selectively disable modules simply
    # by removing them from the following list.  The available modules you
    # can use are: authcustom authcram authuserdb authldap authpgsql authmysql authpam
    
    authmodulelist="authuserdb authpam"
    
    ##NAME: authmodulelistorig:1
    #
    # This setting is used by Courier's webadmin module, and should be left
    # alone
    
    authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"
    
    ##NAME: daemons:0
    #
    # The number of daemon processes that are started.  authdaemon is typically
    # installed where authentication modules are relatively expensive: such
    # as authldap, or authmysql, so it's better to have a number of them running.
    # PLEASE NOTE:  Some platforms may experience a problem if there's more than
    # one daemon.  Specifically, SystemV derived platforms that use TLI with
    # socket emulation.  I'm suspicious of TLI's ability to handle multiple
    # processes accepting connections on the same filesystem domain socket.
    #
    # You may need to increase daemons if as your system load increases.  Symptoms
    # include sporadic authentication failures.  If you start getting
    # authentication failures, increase daemons.  However, the default of 5
    # SHOULD be sufficient.  Bumping up daemon count is only a short-term
    # solution.  The permanent solution is to add more resources: RAM, faster
    # disks, faster CPUs...
    
    daemons=5
    
    ##NAME: version:0
    #
    # When you have multiple versions of authdaemond.* installed, authdaemond
    # just picks the first one it finds.  Set "version" to override that.
    # For example:  version=authdaemond.plain
    
    version=""
    
    ##NAME: authdaemonvar:0
    #
    # authdaemonvar is here, but is not used directly by authdaemond.  It's
    # used by various configuration and build scripts, so don't touch it!
    
    authdaemonvar=/var/run/courier/authdaemon
    
    Login in via webmail doesn't work either. (of course using the correct logins: emailadress for webmail, username for pop3, but other combinations don't work either)
    All users are there in virtualuser table of postfix.

    Any help/hints is greatly appreciated!
     
    Last edited: Oct 19, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change authmodulelist to this:

    authmodulelist="authpam"

    and restart all courier daemons. Which error message do you get in the mail.log?
     
  3. jake

    jake New Member

    Hi thanks for quick reply.

    I modified the file as you said, and restarted the following services:
    courier-authdaemon
    courier-pop-ssl
    courier-pop
    courier-imap
    courier-imap-ssl

    After restarting courier-authdaemon i get the following errors:
    Code:
    /etc/init.d/courier-authdaemon restart
    : command not foundthdaemon: /usr/lib/courier/authlib/authdaemond: line 19:
    : command not foundthlib/authdaemond: line 26:
    : command not foundthlib/authdaemond: line 28:
    : command not foundthlib/authdaemond: line 33:
    : command not foundthlib/authdaemond: line 35:
    : command not foundthlib/authdaemond: line 52:
    : command not foundthlib/authdaemond: line 54:
    : command not foundthlib/authdaemond: line 60:
    : command not foundthlib/authdaemond: line 62:
    : command not foundthlib/authdaemond: line 67:
    done.
    : command not foundthdaemon: /usr/lib/courier/authlib/authdaemond: line 19:
    : command not foundthlib/authdaemond: line 26:
    : command not foundthlib/authdaemond: line 28:
    : command not foundthlib/authdaemond: line 33:
    : command not foundthlib/authdaemond: line 35:
    : command not foundthlib/authdaemond: line 52:
    : command not foundthlib/authdaemond: line 54:
    : command not foundthlib/authdaemond: line 60:
    : command not foundthlib/authdaemond: line 62:
    : command not foundthlib/authdaemond: line 67:
    done.
    
    But still no luck,
    Code:
    telnet xxx.xxx.xxx.xxx 110
    Trying xxx.xxx.xxx.xxx ...
    Connected to xxx.xxx.xxx.xxx .
    Escape character is '^]'.
    +OK Hello there.
    USER web6_drjake
    +OK Password required.
    PASS xxxx
    -ERR Login failed.
    

    the mail.log shows the following entries;
    Code:
    Oct 19 09:41:28 broomhilda imaplogin: Connection, ip=[::ffff:168.144.108.25]
    Oct 19 09:41:33 broomhilda imaplogin: LOGIN FAILED, ip=[::ffff:168.144.108.25]
    Oct 19 09:41:38 broomhilda imaplogin: LOGIN FAILED, ip=[::ffff:168.144.108.25]
    Oct 19 09:41:38 broomhilda imaplogin: DISCONNECTED, ip=[::ffff:168.144.108.25], time=5
    Oct 19 09:41:44 broomhilda courierpop3login: LOGIN FAILED, ip=[::ffff:84.244.15.118]
    Oct 19 10:15:59 broomhilda  : exec: No such file or directory
    Oct 19 10:19:41 broomhilda  : exec: No such file or directory
    Oct 19 10:22:22 broomhilda courierpop3login: Connection, ip=[::ffff:84.244.15.118]
    Oct 19 10:23:02 broomhilda courierpop3login: LOGIN FAILED, ip=[::ffff:84.244.15.118]
    ----
    On a side note: newly added sites do not appear to be created in de vhosts file. I don't think its related but what would cause that?
     
  4. jake

    jake New Member

    OK solved, the vhosts thingie, had an error in config.
    Still haning on the mail stuff tough.

    Thanks already!
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your current authdaemonrc file.
     
  6. jake

    jake New Member

    Thanks,

    Hereby my authdeamonrc:
    Code:
    ##VERSION: $Id: authdaemonrc.in,v 1.8 2001/10/07 02:16:22 mrsam Exp $
    #
    # Copyright 2000-2001 Double Precision, Inc.  See COPYING for
    # distribution information.
    #
    # authdaemonrc created from authdaemonrc.dist by sysconftool
    #
    # Do not alter lines that begin with ##, they are used when upgrading
    # this configuration.
    #
    # This file configures authdaemond, the resident authentication daemon.
    #
    # Comments in this file are ignored.  Although this file is intended to
    # be sourced as a shell script, authdaemond parses it manually, so
    # the acceptable syntax is a bit limited.  Multiline variable contents,
    # with the \ continuation character, are not allowed.  Everything must
    # fit on one line.  Do not use any additional whitespace for indentation,
    # or anything else.
    
    ##NAME: authmodulelist:0
    #
    # The authentication modules that are linked into authdaemond.  The
    # default list is installed.  You may selectively disable modules simply
    # by removing them from the following list.  The available modules you
    # can use are: authcustom authcram authuserdb authldap authpgsql authmysql authpam
    
    authmodulelist="authpam"
    
    ##NAME: authmodulelistorig:1
    #
    # This setting is used by Courier's webadmin module, and should be left
    # alone
    
    authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"
    
    ##NAME: daemons:0
    #
    # The number of daemon processes that are started.  authdaemon is typically
    # installed where authentication modules are relatively expensive: such
    # as authldap, or authmysql, so it's better to have a number of them running.
    # PLEASE NOTE:  Some platforms may experience a problem if there's more than
    # one daemon.  Specifically, SystemV derived platforms that use TLI with
    # socket emulation.  I'm suspicious of TLI's ability to handle multiple
    # processes accepting connections on the same filesystem domain socket.
    #
    # You may need to increase daemons if as your system load increases.  Symptoms
    # include sporadic authentication failures.  If you start getting
    # authentication failures, increase daemons.  However, the default of 5
    # SHOULD be sufficient.  Bumping up daemon count is only a short-term
    # solution.  The permanent solution is to add more resources: RAM, faster
    # disks, faster CPUs...
    
    daemons=5
    
    ##NAME: version:0
    #
    # When you have multiple versions of authdaemond.* installed, authdaemond
    # just picks the first one it finds.  Set "version" to override that.
    # For example:  version=authdaemond.plain
    
    version=""
    
    ##NAME: authdaemonvar:0
    #
    # authdaemonvar is here, but is not used directly by authdaemond.  It's
    # used by various configuration and build scripts, so don't touch it!
    
    authdaemonvar=/var/run/courier/authdaemon
    
    I just checked and reinstalled my courier-authlib, but the errors remain the same:
    Code:
    Stopping Courier authentication services: authdaemond/usr/sbin/authdaemond: line: command not found
    : command not foundnd: line 26:
    : command not foundnd: line 28:
    : command not foundnd: line 33:
    : command not foundnd: line 35:
    : command not foundnd: line 52:
    : command not foundnd: line 54:
    : command not foundnd: line 60:
    : command not foundnd: line 62:
    : command not foundnd: line 67:
    .
    Starting Courier authentication services: authdaemond/usr/sbin/authdaemond: line: command not found
    : command not foundnd: line 26:
    : command not foundnd: line 28:
    : command not foundnd: line 33:
    : command not foundnd: line 35:
    : command not foundnd: line 52:
    : command not foundnd: line 54:
    : command not foundnd: line 60:
    : command not foundnd: line 62:
    : command not foundnd: line 67:
    .
    
    
    On a side note:
    Code:
    broomhilda:~# locate authpam
    Results in:
    Code:
    /usr/share/man/man7/authpam.7.gz
    
     
    Last edited: Oct 20, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    You messed up one of your courier files, maybe the Courier init scripts? Please check all your courier files. It seems you have authdaemond/usr/sbin/authdaemond in one of them.
     

Share This Page