Plus Addressing...

Discussion in 'Installation/Configuration' started by archerjd, Nov 9, 2010.

  1. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    Hello guys,

    I have been trying to configure plus addressing for the last three days and totally failed at it.
    Emails sent from an external mail server with [email protected] comes back with an NDR saying '< #5.1.1 x-unix; Invalid user specified.>'

    As I understand it the email should be sent to the inbox if the folder does not exist.

    My configuration:
    • Debian Lenny
    • ISP Config3 3.0.1.4
    • Postfix/Amavisd-New/Maildrop/Courier

    My tag levels are as follows:
    SPAM tag level = 3
    SPAM tag2 level = 5.5
    SPAM kill level = 6.9

    On the Other tab Addr. extension SPAM is set to 'Junk' without quotes.

    I have reviewed my postfix configuration & I could find nothing wrong with it.
    Code:
    email:~# postconf -n | grep delimiter
    recipient_delimiter = +
    If I need to upgrade to 3.0.3, I can but it'll have to wait as I have many more things pressing for my time.

    Thanks for your help.

    -Archer
     
    Last edited: Nov 9, 2010
  2. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    I believe I have found what's wrong.

    In /etc/postfix/master.cf I have:
    Code:
    maildrop  unix  -       n       n       -       -       pipe
    	flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    
    I found that the installer for ISPC3 changes that like to:
    Code:
    maildrop  unix  -       n       n       -       -       pipe
    	flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    
    Some of the differences were fixed in revision 1353 but I still don't know how I got two ${recipient} options in the config.
     
  3. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    Ok, so that did fix the email being rejected.
    Now email goes into the inbox but not into the desired folder.

    Any tips would be appreciated.
     
  4. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    Ok, so I was able to get the junk mail to work with the following in the .mailfilter file.
    Code:
    SPAMDIR="Junk"
    SPAMDIRFULL="$DEFAULT/.Junk"
    
    if ( /^X-Spam-Flag: YES$/ || /^X-Spam-Level: \*\*\*.*$/ )
    {
      exception {
    
        `test -e $SPAMDIRFULL`
        if ( $RETURNCODE != 0 )
        {
          `maildirmake -f $SPAMDIR $DEFAULT`
          `chown vmail:vmail -R $SPAMDIRFULL`
          `chmod 0700 $SPAMDIRFULL`
          `echo INBOX.$SPAMDIR >> $DEFAULT/courierimapsubscribed`
        }
        to "$SPAMDIRFULL/"
      }
    }
    
    But it still doesn't work for normal plus addressing.
    Shouldn't maildrop handle this automatically? Or do you have to write a custom mailfilter?
     

Share This Page