plenty of procmail/trashscan processes

Discussion in 'Installation/Configuration' started by ZyanKLee, Dec 19, 2005.

  1. ZyanKLee

    ZyanKLee New Member

    ok, the problem concerning the wrong zlib-package was solved.
    what stays are those many many many pairs of procmail- & trashscan-processes
    last time I had a look at them (20 mins after restarting the machine) there were more than 2500 processes only from user admispconfig.

    it looked like this:

    Code:
    # ps -u admispconfig
      PID TTY          TIME CMD
    14994 ?        00:00:00 ispconfig_httpd
    15289 ?        00:00:00 freshclam
    15295 ?        00:00:00 procmail
    15296 ?        00:00:00 procmail
    15297 ?        00:00:00 trashscan
    15305 ?        00:00:00 procmail
    15306 ?        00:00:00 procmail
    15307 ?        00:00:00 trashscan
    15315 ?        00:00:00 procmail
    15316 ?        00:00:00 procmail
    15317 ?        00:00:00 trashscan
    15325 ?        00:00:00 procmail
    15326 ?        00:00:00 procmail
    15327 ?        00:00:00 trashscan
    15335 ?        00:00:00 procmail
    15336 ?        00:00:00 procmail
    15337 ?        00:00:00 trashscan
    15345 ?        00:00:00 procmail
    15346 ?        00:00:00 procmail
    15347 ?        00:00:00 trashscan
    15355 ?        00:00:00 procmail
    15356 ?        00:00:00 procmail
    15357 ?        00:00:00 trashscan
    15365 ?        00:00:00 procmail
    15366 ?        00:00:00 procmail
    15367 ?        00:00:00 trashscan
    15375 ?        00:00:00 procmail
    15376 ?        00:00:00 procmail
    15377 ?        00:00:00 trashscan
    15385 ?        00:00:00 procmail
    15386 ?        00:00:00 procmail
    15387 ?        00:00:00 trashscan
    15397 ?        00:00:00 procmail
    15398 ?        00:00:00 procmail
    15399 ?        00:00:00 trashscan
    15407 ?        00:00:00 procmail
    15408 ?        00:00:00 procmail
    15409 ?        00:00:00 trashscan
    15417 ?        00:00:00 procmail
    15418 ?        00:00:00 procmail
    15419 ?        00:00:00 trashscan
    15427 ?        00:00:00 procmail
    15428 ?        00:00:00 procmail
    15429 ?        00:00:00 trashscan
    15437 ?        00:00:00 procmail
    15438 ?        00:00:00 procmail
    15439 ?        00:00:00 trashscan
    15447 ?        00:00:00 procmail
    15448 ?        00:00:00 procmail
    15449 ?        00:00:00 trashscan
    15457 ?        00:00:00 procmail
    15458 ?        00:00:00 procmail
    15459 ?        00:00:00 trashscan
    15467 ?        00:00:00 procmail
    
    this is only a little part of the whole output I got
     
  2. falko

    falko Super Moderator

    Do you have something like a mail loop? What's in your mail log?
     
  3. ZyanKLee

    ZyanKLee New Member

    these are the last few lines from /var/log/mail

    this is what /var/log/mail.err tells me: (the dying processes may be killed by me, but I'm not sure)

    but actually this tells me nothing. email-daemons are not my world :(
     
  4. falko

    falko Super Moderator

    Ok, you're using Sendmail. Which distribution are you using?

    What's in /etc/mail/sendmail.cf?

    Also, please post the output of
    Code:
    netstat -tap
     
  5. ZyanKLee

    ZyanKLee New Member

    Distro: SuSe 9.2


    /etc/sendmail.cf is located under : http://nopaste.php-q.net/179737
    yeah I know there are many comments in it - but deleting them all would last to long
     
    Last edited: Dec 21, 2005
  6. falko

    falko Super Moderator

    Sendmail isn't running at all! Start it:
    Code:
    /etc/init.d/sendmail start
    The sendmail.cf looks ok, so hopefully your problem will disappear afterwards.
     
  7. ZyanKLee

    ZyanKLee New Member

    oops, no the problem why there was no listening sendmail was: I stopped it, as the server begun to hang itself up.

     
    Last edited: Dec 21, 2005
  8. ZyanKLee

    ZyanKLee New Member

    two minutes after starting sendmail a "ps -Al | less" looks like this:

    it is always the same
     
  9. falko

    falko Super Moderator

    What's in your mail log when you have that many processes and sendmail is running? I guess in your last mail log excerpt sendmail wasn't running.
     
  10. ZyanKLee

    ZyanKLee New Member

    humm, dunno

    but this is a /var/log/mail - excerpt with sendmail running at present


    the last few lines from: ps -Al

     
  11. ZyanKLee

    ZyanKLee New Member

    wanna have a look at the server itself? i think it would be much easier to handle this problem.

    so if you want a login send me a pm
     

Share This Page