Please read before posting!

Discussion in 'General' started by till, Aug 27, 2012.

Thread Status:
Not open for further replies.
  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read this full post, including the FAQ topics.

    Before opening a new thread, please read these guidelines:
    - If your system is malfunctioning, please run the test script and share the output in a code block.
    To start the test, run the following command as root user on your server:

    Code:
    wget -q -O htf-common-issues.php "http://gitplace.net/pixcept/ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues.php
    to view the report, run this command:

    Code:
    cat htf_report.txt | more
    IP addresses are already anonymized in the report, so you can post it safely here in the forum.
    - If you are sharing logs, the output of a command, or the content of config files, put it in a code block like this:
    upload_2021-2-10_12-52-4.gif
    (Insert - Code -> paste the output)
    - Write your normal text outside of the code block.
    - Always share your OS and PHP CLI version.
    You can find your OS version with
    Code:
    lsb_release -a
    and your PHP version with
    Code:
    php -v
    - Share the related software you are using (for example, when you have a question related to your webserver, are you using Apache or NGINX?)
    - Read this FAQ before posting:
    This problem can have 2 causes:
    - You have HTTPS enabled for domain A but not for domain B, will visiting domain B over HTTPS. It is Apache's default behaviour to show the first website in the list that has HTTPS enabled.
    - domain A is listening on * while domain B is listening on a specific IP, or vice versa. Make sure all your webs are listening on a specific IP or *.
    In your Roundcube config (/etc/roundcube/config.inc.php), change Make sure the config for smtp_server is localhost, like this:
    Code:
    $config['smtp_server'] = 'localhost';
    and the smtp_port setting is 25, like this:
    Code:
    $config['smtp_port'] = 25;
    Did you let the update script reconfigure your services? If not, run a forced update and let it reconfigure services with
    Code:
    ispconfig_update.sh --force
    Make sure you don't have any out of date custom config templates in /usr/local/ispconfig/server/conf-custom - update them accordingly before reconfiguring the services.
    It takes about 1 minute until ISPConfig writes changes to disk, ensure that you waited long enough before you test changes. If a job is listed in the jobqueue of the ispconfig monitor, then this job has not been processed yet. Wait until it disappears from the list.
    Debug instructions for the ISPConfig server process are in the FAQ: https://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/
    Make sure you are using the default PHP version for your OS with
    Code:
    update-alternatives --config php
    and
    Code:
    update-alternatives --config php-cgi
    These are the default versions that should be used:
    Debian 9: PHP 7.0
    Debian 10: PHP 7.3
    Ubuntu 16.04: PHP 7.0
    Ubuntu 18.04: PHP 7.2
    Ubuntu 20.04: PHP 7.4
    CentOS 7: PHP 5.4
    CentOS 8: PHP 7.2

    This issue can be caused by installing/updating a (new) PHP version.
    Are you able to send and receive emails with webmail? A easy test if the local mailsystem works is to login to webmail with a account hosted on the server and send a email to the same address that you used to login to webmail. The email shall arrive within a minute back to your account when the local mailsystem works. If the email does not arrive, post the error message(s) that you get in the mail log file when the problem occurs. The mail log file is in the folder /var/log/, it is named "mail.log" on Debian and Ubuntu Linux and named "maillog" on other distributions.
    - Which webserver software do you use, apache or nginx?
    - Post the errors that you find in the global webserver error.log and the ones from the error.log of the website. The global log file is e.g. in /var/log/apache2/ for the apache server and the website error log is in /var/www/yourdomain.tld/log/
    This is a known bug in ISPConfig 3.2.3, which occurs after changing server config. It is fixed in 3.2.4. You can use this as temporary work around:
    Code:
    wget -O /usr/local/ispconfig/server/conf/apache_ispconfig.conf.master https://git.ispconfig.org/ispconfig/ispconfig3/-/raw/3.2.3/install/tpl/apache_ispconfig.conf.master
    echo "DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm standard_index.html" >> /etc/apache2/sites-available/ispconfig.conf
    systemctl restart apache2
    - Have you waited long enough? Changes in DNS may take up to 24 hours until they propagate to all dns caches. If you like to test the local dns server for a domain name without waiting for the caches to renew, use this command:
    Code:
    dig @localhost yourdomain.tld
    replace yourdomain.tld with the domain name that you want to query your local dns server for.
    - If the nameservers (ns records) of the zone are subdomains of the zone, then ensure that you created A-Records for the ns1 and ns2 server in the zone as well and it might be nescessary to add glue records in the dns server of the domain registry.
    - Post the errors of the named daemon (the BIND dns server logs under the name named) from /var/log/syslog


    --- Post History ----------------------------------------------------
    2013/11/28: Added ISPConfig test script.
    2021/02/10: Big update to the post, which is now shown in General and Installation/Configuration.
    2021/02/15: Added FAQ info for the correct PHP version of the OS.
     
    Last edited by a moderator: Apr 8, 2021
    atle, etruel, Alacarga and 8 others like this.
Thread Status:
Not open for further replies.

Share This Page