PLEASE HELP STUCK with Upgrade ISPConfig 3.1.1p1 + System = SMTP-Server OFFLINE

Discussion in 'ISPConfig 3 Priority Support' started by Petar, Dec 10, 2016.

  1. Petar

    Petar New Member HowtoForge Supporter

    Hi dear friends and colleagues, i'm stuck this weekend with urgent situation.

    I had a Debian 8.6 + ISPc3.1 based on your tutorial and having no big problems until today.
    On a system which was perfectly working, I did a ISPc upgrade to 3.1.1p1 and apt-get update+upgrade then reboot.
    For the ISPc upgrade i did ispconfig_update.sh and followed the ordinary procedure without changing anything.
    In ISPc monitor I can see 2 warnings:
    1. SMTP server Offline
    2. Inst python-dnspython and other files needed for upgrade (i did the update+upgrade and still it lists them as not upgraded)
     
  2. Petar

    Petar New Member HowtoForge Supporter

    Found one more problem:
    when checking: amavisd-new testkeys
    i get error:
    TESTING#1 mydomain.com: default._domainkey.mydomain => invalid (public key: not available)

    I deleted the DKIM/DMARC from ISPC, generated a new key from email and recreated DKIM/DMARC, but nothing changes, i still got the same error. Probably this two errors are somehow connected?

    Anybody to help me solve this problem and go home for the weekend :(
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact errors do you get in the mail log file when you restart postfix?
     
  4. Petar

    Petar New Member HowtoForge Supporter

    Nothing strange, just:
    Dec 11 12:31:49 web32c1d postfix/master[1252]: terminating on signal 15
    Dec 11 12:31:50 web32c1d postfix/master[12058]: daemon started -- version 2.11.3, configuration /etc/postfix

    At the ISPc monitor i've got info that some installs are not done like:
    Inst python-dnspython (1.12.0-1 Debian:8.6/stable [all])
    Inst python-certbot-apache [0.8.1-1~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all]) []
    Inst certbot [0.8.1-2~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all]) []
    Inst python-certbot [0.8.1-2~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all]) []
    Inst python-acme [0.8.1-1~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf python-dnspython (1.12.0-1 Debian:8.6/stable [all])
    Conf python-acme (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf python-certbot (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf certbot (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf python-certbot-apache (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])

    And when trying to do the updates, i got:
    The following packages have been kept back:
    certbot python-acme python-certbot python-certbot-apache

    I guess this has some problem with dependencies...


    SYSLOG:

    Dec 11 12:31:49 web32c1d systemd[1]: Stopping Mail Transport Agent.
    Dec 11 12:31:49 web32c1d systemd[1]: Stopping LSB: Postfix Mail Transport Agent...
    Dec 11 12:31:49 web32c1d postfix/master[1252]: terminating on signal 15
    Dec 11 12:31:49 web32c1d postfix[11921]: Stopping Postfix Mail Transport Agent: postfix.
    Dec 11 12:31:49 web32c1d systemd[1]: Starting LSB: Postfix Mail Transport Agent...
    Dec 11 12:31:50 web32c1d postfix[11947]: Starting Postfix Mail Transport Agent: postfix.
    Dec 11 12:31:50 web32c1d systemd[1]: Started LSB: Postfix Mail Transport Agent.
    Dec 11 12:31:50 web32c1d systemd[1]: Starting Mail Transport Agent.
    Dec 11 12:31:50 web32c1d systemd[1]: Reached target Mail Transport Agent.
    Dec 11 12:31:50 web32c1d postfix/master[12058]: daemon started -- version 2.11.3, configuration /etc/postfix


    REBOOT: I found this in daemon.log:

    Dec 11 12:50:29 web32c1d amavis[605]: amavisd-new.
    Dec 11 12:50:29 web32c1d systemd[1]: Started LSB: Starts amavisd-new mailfilter.
    Dec 11 12:50:29 web32c1d systemd[1]: Starting LSB: Startup script for amavis master supervisor...
    Dec 11 12:50:29 web32c1d amavis-mc[1206]: Not starting amavis-mc - edit /etc/default/amavis-mc to enable it ... (warning).
    Dec 11 12:50:29 web32c1d systemd[1]: Started LSB: Startup script for amavis master supervisor.
    Dec 11 12:50:29 web32c1d systemd[1]: Starting LSB: Startup script for amavis snmp subagent...
    Dec 11 12:50:29 web32c1d amavisd-snmp-subagent[1217]: Not starting amavisd-snmp-subagent - edit /etc/default/amavisd-snmp-subagent to enable it ... (warning).
    Dec 11 12:50:29 web32c1d systemd[1]: Started LSB: Startup script for amavis snmp subagent.
     
    Last edited: Dec 11, 2016
  5. Petar

    Petar New Member HowtoForge Supporter

    Anybody had the same problem or has some idea what to check or reinstall?
    Did someone managed to update: certbot python-acme python-certbot python-certbot-apache?

    Thanks in advance for your help and communication!
     
  6. Petar

    Petar New Member HowtoForge Supporter

    I did the ISPc test script and found in the result:
    [WARN] I found no "smtp" entry in your postfix master.cf

    Then i checked the /etc/postfix/master.cf and remembered that i changed several lines to include different mail servers for different IP:
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    localhost:smtp inet n - - - - smtpd
    5.189.xxx.xx1:smtp inet n - - - - smtpd -o myhostname=mail.first-domain.com
    5.189.xxx.xx3:smtp inet n - - - - smtpd -o myhostname=mail.second-domain.com

    I guess this could be the problem for the initial "SMTP server Offline" message in ISPc monitor and in htf_report.txt

    Can somebody check my syntax in the master.cf and guide me if there some other place where i should put smtp settings?
    Thanks in advance
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The smtp settings are in master.cf and in the amavisd configuration file(s). I would use 127.0.0.1 instead of localhost in master.cf, but it might work as well like you defined it, I did not tested that.
     
  8. Petar

    Petar New Member HowtoForge Supporter

    Hello Till,

    Thanks for the support.
    As you can see, i have in the master.cf for the localhost:
    localhost:smtp inet n - - - - smtpd

    Do you say, that i should ad one more for the 127, like this:

    127.0.0.1:smtp inet n - - - - smtpd
    ?
    And what should i add and where to the amavisd files?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    If it works now, the leave it as it is. If it does not work, then try to change it.

    It might be that there is no change necessary. Which error message do you get now when you receive an email?
     
  10. Petar

    Petar New Member HowtoForge Supporter

    As i wrote earlier, there is no message while sending and receiving.
    In ISPc monitor i get 1 service offline (SMTP) and
    I did the ISPc test script and found in the result:
    [WARN] I found no "smtp" entry in your postfix master.cf

    and here is the master.cf

    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    localhost:smtp inet n - - - - smtpd
    5.189.xxx.xx1:smtp inet n - - - - smtpd -o myhostname=mail.first-domain.com
    5.189.xxx.xx3:smtp inet n - - - - smtpd -o myhostname=mail.second-domain.com
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Replace localhost with 127.0.0.1 and restart postfix. ISPConfig will report postfix as offline when it is not listening on the localhost IP.
     
    Petar likes this.
  12. Petar

    Petar New Member HowtoForge Supporter

    I guess that was the problem.
    Instead of localhost, it should be:
    127.0.0.1:smtp inet n - - - - smtpd -o myhostname=localhost

    Now the ISPConfig Monitor is blue (because of the dependency updates) and not red!
    Thanks for the superb guiding, help and support Till.
    Regards for your whole crew, all the best.

    [CLOSED]
     

Share This Page