PLEASE HELP!!! Postfix master service is stop, after change a NFS HDD

Discussion in 'Installation/Configuration' started by W-C, Jun 30, 2017.

  1. W-C

    W-C New Member

    Hello,

    I Just replace and nfs hard disk that was running out of space, the mail service see the new hdd and it contains all mails since a rsync -apvh command was running to copy all files and permissions.

    When I check the status of Postfix server it shows the following:
    [[email protected] log]# service postfix status
    master is stopped

    When I try to start the service the logs shows the following:
    ==============================================================
    Jun 30 01:57:27 mail postfix/postfix-script: starting the Postfix mail system
    Jun 30 01:57:27 mail postfix/master[10908]: fatal: bind 127.0.0.1 port 25: Address already in use
    ===============================================================

    I tried once again and the logs are:
    Jun 30 02:00:33 mail postfix/postfix-script: fatal: the Postfix mail system is not running
    Jun 30 02:00:34 mail postfix/postfix-script: starting the Postfix mail system
    Jun 30 02:01:57 mail postfix/postfix-script: starting the Postfix mail system
    =========================================================

    If I start the sendmail service I can sent email succesfully.

    I have another server that is working and when I tried to send an email to an account on the fault server the logs shows the following:
    Jun 30 01:36:04 mail postfix/smtp[26875]: 876F6E058E: to=<[email protected]>, relay=none, delay=0.53, delays=0.29/0/0.24/0, dsn=4.4.1, status=deferred (connect to mail.domain.com[192.168.1.1]:25: Connection refused)

    **For security reasons I changed the IP

    The server is running over centos 5.5 and ISP Config 3

    Thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    seems as if another software uses port 25, probably sendmail. stop sendmail and then start postfix.
     
    W-C likes this.
  3. W-C

    W-C New Member

    Hello Till,

    I already try that and It did not work
    =============================
    [[email protected] log]# service sendmail status
    sendmail is stopped
    [[email protected] log]# service postfix status
    master is stopped
    [[email protected] log]# service postfix start
    Starting postfix: [ OK ]
    [[email protected] log]# service postfix status
    master is stopped
    [[email protected] log]#
    ===========================

    Thanks in advance for your help
     
  4. W-C

    W-C New Member

    Till,

    I found this in the log when I tried to restart the service again:


    ================================
    Jun 30 02:24:43 mail postfix/postfix-script: starting the Postfix mail system
    Jun 30 02:24:43 mail postfix/master[15279]: fatal: bind 2803:d200:0:4000::185 port 25: Cannot assign requested address
     
  5. W-C

    W-C New Member

    this is another log when I tried to send a mail with the service sendmail stop:
    Jun 30 02:33:26 mail sendmail[16602]: v5U8XP7X016602: to=[email protected] ctladdr=[email protected] (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=30587, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    check with:

    netstat -ntap

    if port 25 is not in use and if it is in use, try to stop the program that uses it or kill the process that uses it.

    Sendmail is not used or configured on your system, so it is likely that it throws errors when it gets started.
     
  7. W-C

    W-C New Member

    Till,

    It seem no service is using 25 port:


    I don't know if this log is telling me which IP is using port 25:
    Jun 30 02:56:42 mail postfix/postfix-script: starting the Postfix mail system
    Jun 30 02:56:42 mail postfix/master[4617]: fatal: bind 2003:d200:0:40c::140 port 25: Cannot assign requested address

    It seems that the IPv6 2003:d200:0:40c::140 is using that port. I am wrong? How can I tell the system not look for IPv6 for port 25?
     
    Last edited: Jul 1, 2017
  8. W-C

    W-C New Member

    this is the log when I tried to send an email:
    Jun 30 03:07:33 mail sendmail[6283]: v5U97XD8006283: to=[email protected] ctladdr=[email protected] (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30576, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
     
    Last edited: Jul 1, 2017
  9. W-C

    W-C New Member

    till,

    I already found the issue, there was a line in the master.cf file telling postfix to bind smtp to the IPv6 show in the logs.

    The IPv6 was no longer available, I commented that line and reload the services.

    Thanks for all your help.
     
  10. W-C

    W-C New Member

    Hello till,

    After this changes the forward options are only working in one domain, could you please let me know which parameters i can check in order to test the forward option.


    Thanks in advance...
     

Share This Page