Please help for slow server problem

Discussion in 'Installation/Configuration' started by alex916, Feb 8, 2007.

  1. alex916

    alex916 New Member

    Hi, i have a problem with Isp config.
    I followed Perfect debian setup with a p4 2.8 ram 512 hd 80gb pc.
    My server run very slow, this sometimes not always.
    i have 2 domain and a total of 90 user.
    This is the top output if it is usefull:
    top - 12:19:10 up 5 days, 4:17, 1 user, load average: 97.96, 89.91, 84.14
    Tasks: 303 total, 52 running, 241 sleeping, 0 stopped, 10 zombie
    Cpu(s): 50.0% us, 50.0% sy, 0.0% ni, 0.0% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 450892k total, 446220k used, 4672k free, 1636k buffers
    Swap: 1317288k total, 671632k used, 645656k free, 55652k cached

    From top command, seem that i have a lot of spamassasin task running.
    I don't know very well linux.
    Thank you
    Alex
     
  2. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Spamassassin is a memory killer. OTOH, it only comes to action when an email is received (as per default, things may be different when you tweaked your installation). You have 512K for 90 users, which is rather low. How much messages do you get per hour on average?

    When no mail is being received, there should not be any spamassassin process. Might be worth to investigate why there are so many processes left. You also have 10 zombies ("dead" processes). Could those be those spamassassin ones?

    You might try to get rid of these by stopping starting ISPConfig, but I'm afraid you'll have to reboot the server. Watch the swap space being used. As soon as that happens your system will slow down significantly.
     
  3. alex916

    alex916 New Member

    So, if i remove the spam control, i will resolve the problem in your opinion?
    Thank you
     
  4. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Yes, at the cost of having much more spam in the users inboxes. So this is only a temp workaround IMHO.
     
  5. alex916

    alex916 New Member

    I tried to stop isp_config and reboot the server but after it i'm always with the problem
    top - 13:42:24 up 9 min, 2 users, load average: 78.61, 64.01, 32.97
    Tasks: 419 total, 1 running, 381 sleeping, 0 stopped, 37 zombie
    Cpu(s): 4.6% us, 1.3% sy, 0.0% ni, 0.0% id, 93.4% wa, 0.7% hi, 0.0% si
    Mem: 450892k total, 448196k used, 2696k free, 1228k buffers
    Swap: 1317288k total, 688136k used, 629152k free, 12500k cached


    There is a solution for reset all this task and restart

    Thanks
     
  6. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Something is completely clogging your system. And it's very IO intensive (look at wait time, that's waiting for disks data to be returned to the requesting program). Also, you now have even 37 zombies. That's worse then before. What's the output of
    Code:
    ps -ef | grep defunct
    ?
     
  7. alex916

    alex916 New Member

    martinfst i don't know how thank you.
    Well, the problem seem to be a mail sended in the morning from a user to 50 user with an attachment of 4MB.
    Now the top say
    top - 14:12:52 up 40 min, 3 users, load average: 27.07, 46.73, 61.66
    Tasks: 85 total, 2 running, 83 sleeping, 0 stopped, 0 zombie
    Cpu(s): 9.6% us, 1.3% sy, 0.0% ni, 0.0% id, 88.7% wa, 0.3% hi, 0.0% si
    Mem: 450892k total, 313392k used, 137500k free, 2864k buffers
    Swap: 1317288k total, 265372k used, 1051916k free, 28904k cached

    and go down.
    Sorry for my english ;)

    Thanks again for your support.
     
  8. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    :confused:
    Spamassassin should skip such large files by default, as these are normally not spam. IIRC, the default is to leave alone any email larger then 250k.

    I tried to quickly find the settings for ISPConfig, but not sure where to look and I don't have time to investigate further. Till, Falko?
     
  9. alex916

    alex916 New Member

    Well, seem that to process an email, spamassassin and clamscan use a lot of time.
    I see that for every mail, there is a mail to admispconfig@localhost.localdomain, why?

    And yes, clamav e spamassasin scan all mail.

    Alex
     
    Last edited: Feb 8, 2007
  10. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    That's an adminstrative email to count the used bandwith/bytes for email. These are really small emails and should not be of much problem. I'm still wondering why ISPConfig does not follow the default of SA to skip large emails.
     
  11. alex916

    alex916 New Member

    Can i remove spamassassin snd clam from mta for testing?
    For example, change some line in main.cf?


    This is the "ps -ef | grep defunct" output

    mail:/home/admispconfig/ispconfig/files# ps -ef | grep defunct
    ***16822 16812 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16826 16811 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16843 16817 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16880 16836 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16892 16835 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16903 16815 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16907 16896 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16953 16879 0 15:14 ? 00:00:00 [sh] <defunct>
    ***16967 16900 0 15:14 ? 00:00:00 [sh] <defunct>


    ALex
     
    Last edited: Feb 8, 2007
  12. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Yes, (and I now also found the filesize limit).

    In the top directory of you web (/var/www/web1 or something), there is a file called .procmailrc. It describes which tests to include for mails to that domain. Comment the spamassassin line. Mind that ISPConfig overwrites this file when you change a mail setting of the user.

    An even better idea pops up now that I type this: You can reset the tickbox in ISPConfig for the user mail. (Spam and Antivirus). You can disable SA very easy this way, even per user.
     
  13. alex916

    alex916 New Member

    I'm trying all but the server go slowly.
    I have a lot of mail in postfix queue like 300...delete all queue could be a good solutions?
    Could be a hardware problem? (Stopping postfix all seem to work fast)
    Reinstall Ispconfig could help?

    Please, i don't know what i have to do.

    Thanks
    Alex
     
  14. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    If you can afford to delete your mail queue (e.g your users will not go mad, because you delete legitimate mail), that might help. Otherwise, let it process and in quite hours your system will catch up.

    Anyway, consider a memory upgrade, if possible.

    A re-install of ISPConfig will not help at all. That would be a waste of resources (time and effort).
     
  15. alex916

    alex916 New Member

    Martinfst thank you very much.
    In the morning upgrade memory to 1gb and now the server seem to go very well, in 2 hour it processed all the old queue.
    Thank you again
     

Share This Page