Please help! DKFILTER problem.

Discussion in 'HOWTO-Related Questions' started by chantown, Mar 17, 2008.

  1. chantown

    chantown New Member

    Hi everybody,

    I've followed almost every instruction from many websites (including HowToForge) to install DKFILTER on my postfix. I've spent 24+ hours reformatting and reinstalling everything. I still can't get my DKFILTER to work.

    I have checked my DNS TXT records online, and they seem to be fine. The problem is that when I view Maillogs, I see:

    Code:
    Mar 17 01:12:27 schoogo postfix/postfix-script: fatal: the Postfix mail system is not running
    Mar 17 01:12:27 schoogo sendmail[6455]: alias database /etc/aliases rebuilt by root
    Mar 17 01:12:27 schoogo sendmail[6455]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Mar 17 01:12:27 schoogo postfix/postfix-script: starting the Postfix mail system
    Mar 17 01:12:27 schoogo postfix/master[6501]: fatal: bind 127.0.0.1 port 25: Address already in use
    Mar 17 01:12:50 schoogo sendmail[6526]: m2H6CoFJ006526: from=apache, size=229, class=0, nrcpts=1, msgid=<[email protected]>, [email protected]
    Mar 17 01:12:50 schoogo sendmail[6527]: m2H6Coev006527: from=<[email protected]>, size=448, class=0, nrcpts=1, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
    Mar 17 01:12:50 schoogo sendmail[6526]: m2H6CoFJ006526: [email protected], ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30229, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (m2H6Coev006527 Message accepted for delivery)
    Mar 17 01:12:51 schoogo sendmail[6529]: m2H6Coev006527: to=<[email protected]>, ctladdr=<[email protected]> (48/48), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=120448, relay=gmail-smtp-in.l.google.com. [64.233.167.27], dsn=2.0.0, stat=Sent (OK 1205734371 f6si51316835pyh.13)
    Mar 17 01:14:20 schoogo postfix/postfix-script: fatal: the Postfix mail system is not running
    
    I don't even see DKFILTER in my maillog anywhere!
    Of course, my outbound emails don't get signed. But they do get delivered.

    My DKFILTER process is running. I checked by typing "ps aux".
    I've also tried adding the pickup line in another manual:
    pickup fifo n - n 60 1 pickup
    -o content_filter=dksign:127.0.0.1:10027

    I am sending these emails through PHP mail() function.
    The PHP.ini configuration for sendmail is:
    sendmail_path = /usr/sbin/sendmail -t -i

    Also, I do not have TLS or SMTP-AUTH enabled, as I heard that these conflict with domainkeys.


    I installed DKFILTER but it doesn't seem to work. Could it be that my sendmail is still getting in the way? Can anyone find out what's going on for me?

    Thank you so much!
     
    Last edited: Mar 17, 2008
  2. chantown

    chantown New Member

    Note: I did not install dk-MILTER. What does this mean? Do I need that?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  4. chantown

    chantown New Member

    HI falko, thank you for your reply.

    I've reformmatted my system yet again, and now I tried to install Domainkeys using the tutorial TopDog wrote.

    http://howtoforge.com/forums/showthread.php?t=21455

    I got domainkey to sign, but the problem is that it's not "right" for some reason.

    Thanks,
    Alex
     

Share This Page