PIX & ISPConfig

Discussion in 'Installation/Configuration' started by ACDII, Apr 14, 2008.

  1. ACDII

    ACDII Member

    I have a server that I am deploying which will eventually replace one I have now that is running ISPConfig just fine. The difference between them is the new one is completely behind a PIX. I found an issue though and wonder if there is a work around.

    I am using one public IP address mapped to the IP of the server, ISPConfig site comes up just fine, but instead of me getting to one of the three sites configured, I get the shared IP page. If I tack:81 onto any one of the dns names I get the configuration page telling me the server isnt getting the DNS name request for the site. Other than reconfiguring the server like the one currently deployed with a public and private address on it, how can I get this to work using one public IP on the firewall?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you select the internal IP for the sites in ISPConfig and not the external IP.
     
  3. ACDII

    ACDII Member

    The box only has the private address on it. I think problem is the PIX is stripping off something that ISPConfig needs in order to pull up the correct page.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    , and what's in Vhosts_ispconfig.conf?
     
  5. ACDII

    ACDII Member

    I have a workaround in place, I changed one of the NICS to a different public address and added it to the ISPConfig settings. I can access the pages now so I know the server is configured properly, so this appears to be an issue with the PIX and not the server. I have 2 sites plus the :81 site working on the one IP address. I was hoping I could use this behind a firewall with one IP address, but unless I can figure out how to pass the header information through(website.domain.com) I dont think I can get it to work. All I get is the shared IP index.html page in the sharedip folder, confirming it by modifying that page. It appears the server isnt seeing the URL.
     

Share This Page