Piping email to php script (Virtual Users And Domains With Postfix, Courier & MySQL)

Discussion in 'HOWTO-Related Questions' started by acoghlan, Sep 4, 2009.

  1. acoghlan

    acoghlan New Member

    I have used the article Virtual Users And Domains With Postfix, Courier And MySQL (CentOS 5.1) to build a number of servers now: I really like it and it's solved a number of issues - especially after implementing some of the tweaks in the comments on the article.

    I am now trying to pipe certain emails to our support system, and I just cant get it to work.

    The idea is that any email coming into issue-999@support.domain.com would route through to a specified php file and be processed in a specified way.

    I am confident that the instructions in our support system will be correct in as much as specifying the syntax for getting their php script to work, however I cant get postfix to actually divert any email to the script.

    At the moment I am using a catch all email account, using a forwarder @support.domain.com => address@support.domain.com. Regardless of what I try postfix always sends the inbound message to the forwarder. If I remove the forwarder entry from the table, then the message is bounced back to sender with an 'address not found' error.

    Would you be able to give me a hint on how this is done? Better yet, if you could throw together another tutorial (because I know these things take no time at all to put together!) describing how to extend the excellent tutorial to piping email to different places, that would be brillient.

    Regards

    Andrew
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. acoghlan

    acoghlan New Member

    The system that I am using for support tickets (Eventum from MySQL) suggests these steps for postfix:

    That doesnt seem to work at all with this virtual mail setup, and I am not sure that maildrop is the way to go either - surely this is a native postfix thing as there are many apps that make use of this type of functionality - I just cant work it into this server setup....
     
    Last edited: Sep 5, 2009

Share This Page