phpMyAdmin version package available for ISPConfig

Discussion in 'General' started by Hans, Nov 22, 2007.

Thread Status:
Not open for further replies.
  1. Hans

    Hans Moderator ISPConfig Developer

    Today i've created a phpMyAdmin package for ISPConfig.
    The package is based on version, which is a security fix.
    For release information have a look here:

    For security reasons, I also added the following to the configuration file called, so that some databases will be hidden:

    $cfg['Servers'][$i]['hide_db'] = '(information_schema|mysql|pmadb|test)';

    Update instructions:
    Remove the old phpMyAdmin version first before you install this new package on your ISPConfig server!
    You can do this with the following commands:
    rm -r /home/admispconfig/ispconfig/web/phpmyadmin
    rm /home/admispconfig/ispconfig/web/phpmyadmin.tar.gz
    rm -r /home/admispconfig/ispconfig/web/tools/tools/phpmyadmin

    The package can be downloaded here:

    The new phpMyAdmin package can be installed with the update manager within ISPConfig. :)

    Attached Files:

    Last edited: Nov 22, 2007
  2. edge

    edge Active Member Moderator

    Thank you for the update.

    I guess you are back home again. Did you have any problems with the earthquake?
  3. Hans

    Hans Moderator ISPConfig Developer

    Hi Edge,

    Yes, i am back again. No we did not have any problems. South America is really a big continent, so we did not notice the earthquake at all, only in the news.
  4. all-expert

    all-expert New Member

    not able to install

    when am trying to upload the pkg file i am gettying this error,

    i already copied the unzip of my system to the admispconfig

    that is

    cp /urs/bin/unzip /home/admispconfig/ispconfig/tools/unzip/unzip

    but still the error is:

    Installation instructions not found: /home/admispconfig/ispconfig/temp/077381b019747cc6dc409f39e82155a6/package.ins

    Need help :)

  5. falko

    falko Super Moderator ISPConfig Developer

    unzip comes with ISPConfig, so you don't have to copy anything...
  6. all-expert

    all-expert New Member

    yes fixed, thanks falko :) it was corrupted file :p downloaded again
  7. ditCh

    ditCh New Member

    Tx !

    Upgraded with no problem :)
  8. lubos

    lubos New Member

    download not possible?

    Hi I tried to download but link is not working. And it look to me as typo:

    this double slash after .org is intentional?

    still not working even with one slash only :(

    ISPConfig update error message: Warning: fopen() [function.fopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/admispconfig/ispconfig/web/admin/update/install.php on line 55

    Warning: fopen( [function.fopen]: failed to open stream: Success in /home/admispconfig/ispconfig/web/admin/update/install.php on line 55

    The following error occurred: file_open_error

    And the same error is even when I use just one slash after .org

    Any sugestions?
    Thanks upfront
  9. Hans

    Hans Moderator ISPConfig Developer

    Last night, i moved my servers to a new datacenter. I had a short downtime. The servers are up and running again :) Don't forget you also can download the package from the downloadsection at ;)
  10. lubos

    lubos New Member

    Hi Hans
    thanks for reply - I installed PHPmyadmin from ISPConfig download section day before yesterday and it was version 2.6 - that is why I wanted to use your post. Thank you for this packege ;) Will do update now.

    Update: Installation OK :D

    and this double slash is intentional ;)
    Last edited: Nov 30, 2007
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The version on the ISPConfig page is and not 2.6. It is the same package build by Hans.
  12. lubos

    lubos New Member

    Hi Till - I installed from ISPconfig (copy link and used update in management) and after when I went to https://server.domain.tld:81/phpmyadmin/index.php
    I had in right top corner 'phpMyAdmin - 2.6.x.x'
    Now as I think about this - I installed phpmyadmin before from debian depository independently to ISPConfig and did not deleted it before installing from ISPConfig. Maybe that this was not overwritten and so I had still old installation from debian?
    Anyway I did deleted old PHPmyadmin yesterday as Hans stated in his initial post and today I installed without flaws.
  13. DrAgOOn

    DrAgOOn New Member

    Thanks for the updated package ... Installation OK!

    One little change I made after the install. I prefer to use 'cookie' authentication.

    I know this installation is only for ispconfig .. has anyone setup a package for sites? One install that will work with all domains? either sub-domain or /phpMyAdmin
  14. falko

    falko Super Moderator ISPConfig Developer

    You could use an Apache rewrite rule to accomplish this:
  15. Hans

    Hans Moderator ISPConfig Developer

Thread Status:
Not open for further replies.

Share This Page