phpMyAdmin version 2.11.0 package available for ISPConfig

Discussion in 'General' started by Hans, Sep 8, 2007.

  1. Hans

    Hans Moderator ISPConfig Developer

    Today i've made a new phpMyAdmin package for ISPConfig.
    It is based on the latest stable version phpMyAdmin 2.11.0.

    It can be downloaded here:

    Remove the old phpMyAdmin version first before you install this new package on your ISPConfig server!
    You can do this with the folowing commands:
    rm -r /home/admispconfig/ispconfig/web/phpmyadmin
    rm /home/admispconfig/ispconfig/web/phpmyadmin.tar.gz
    rm -r /home/admispconfig/ispconfig/web/tools/tools/phpmyadmin

    After that the new phpMyAdmin package can be installed with the update manager within ISPConfig.

    Have fun! :)

    Attached Files:

    Last edited: Sep 14, 2007
  2. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Any idea how to completely hide default databases for clients when phpmyadmin is used? They have acces to default databases test and information_schema i dont thing this is secure..
  3. Hans

    Hans Moderator ISPConfig Developer

    Hiding a database from the database list within phpMyAdmin

    If, for example you don't want to show the database "information_schema" within the database list, do the following:

    Change the line no.87 within /home/admispconfig/ispconfig/web/phpmyadmin/ from:

    $cfg['Servers'][$i]['hide_db'] = ''; // Database name to be hidden from listings


    $cfg['Servers'][$i]['hide_db'] = 'information_schema'; // Database name to be hidden from listings

    Of course you can create an array with database names if you don't want to show them within the database list. This means that you can add an extra line for the database 'test' in the same way as well.
    Last edited: Sep 9, 2007
  4. madmucho

    madmucho ISPConfig Developer ISPConfig Developer


    Thanks for fast reply. Simply works :)

    $cfg['Servers'][$i]['hide_db']       = '(test|information_schema)';   
  5. Menzor

    Menzor New Member

    Messed up on the update

    Let me start off with what i started out trying to do. I am trying to enter stored procedures into PHPMyAdmin.

    I am running ISPConfig 2.2.13

    I am not sure what version of PHPMyAdmin I was running, but it definitely was working.

    I realized that the version of PHPMyAdmin that i had did not support stored procedures.

    So i checked the and seen the new version of PHPMyAdmin 2.11.0.

    I downloaded phpmyadmin-2.11.0.pkg witch is 4.247 MB in size.

    I went into ISPConfig update tool and clicked update, I received the install successful, and then clicked on the PHPMyadmin Link on the tools menu. I knew then i did something wrong. When the window opened, instead of getting the normal PHPMyAdmin Window....all i got was a spinning indicator that the page was trying to load, no error, no indication of anything....just a blank page.

    I then looked through the forums and found this thread, and realized i should have done

    rm -r /home/admispconfig/ispconfig/web/phpmyadmin
    rm /home/admispconfig/ispconfig/web/phpmyadmin.tar.gz
    rm -r /home/admispconfig/ispconfig/web/tools/tools/phpmyadmin

    I then ran these commands and was asked if i wanted to descend into each directory, after entering y a number of times, i realized that i needed to remove the files under the directory so I used an FTP program and removed the directories and files under the three folders, and the folders them selves.

    I then reinstalled the PHPMyAdmin 2.11.0. using the update file upload tool in ISPConfig.

    After clicking the PHPMyAdmin Link under the tools menu, I then received the same spinning browser icon and a blank page.

    That is all i get when clicking the PHPMyAdmin tool icon in ISPConfig.....

    Any idea how i can correct this? Or install the previous PHPMyadmin package that worked? I can not seem to find the download for the old package.

    Any Help is greatly appreciated.
  6. Menzor

    Menzor New Member


    Even tried

    same thing.....blank page
  7. Telesat

    Telesat ISPConfig Developer ISPConfig Developer

    Have you tried with another browser?

    I've installed it as explained here and I'm having the very same issue in Firefox: first time it was fine but after that I'm getting the neverending sipinning logo and a blank grey page.

    But I've tried with konqueror and it opens fine. So I guess it has to do with the browser's cache or something like that.

    I think you did it right by removing the files and re-installing phpmyadmin. Just try with another browser and tell us how is it goin.
  8. Hans

    Hans Moderator ISPConfig Developer

    Before you perform an update with the update manager within ISPConfig, you MUST first take those steps (logged in as root):

    rm -r /home/admispconfig/ispconfig/web/phpmyadmin
    rm /home/admispconfig/ispconfig/web/phpmyadmin.tar.gz
    rm -r /home/admispconfig/ispconfig/web/tools/tools/phpmyadmin

    (With those commands, the current phpMyAdmin package on your server will be removed completely).

    AFTER THAT, you can use the update manager NOT before, otherwise you will mix up the previous phpMyAdmin version with the new one.

    Before i published the new phpMyAdmin 2.11.0 package, i tested it thoroughly. I am sure that the package has been build perfectly.

    If you still got problems after a right install procedure, the previous package is still available here:

    But i am sure a step back to the previous version is not a solution, the new phpMyAdmin 2.11.0 package should work!
    Last edited: Sep 14, 2007
  9. Menzor

    Menzor New Member

    Now working

    I know have, everything working.

    The final thing i did was to change permissions on the php files and it phpMyAdmin worked.

Share This Page