phpmyadmin url not found

Discussion in 'HOWTO-Related Questions' started by Scot, May 22, 2014.

  1. Scot

    Scot New Member


    I am very new to linux but was able to get a local server setup going by following this tutorial:

    The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)

    Everything seems to be working except that I can't access phpmyadmin. The tutorial doesn't say exactly how to access phpmyadmin, but other tutorials gave the url below. If I try it, though, I get "The requested URL /phpMyAdmin/ was not found on this server." (or /phpmyadmin/)

    I've also tried localhost/phpmyadmin, ( is one of the local domains I set up for testing), tried with my IP address, and tried including the port 8081 as well.

    I've spent hours searching the web and various forums, including here, but nothing I've tried has worked yet. Any ideas or troubleshooting steps will be very much appreciated.

    Remember I'm very new to linux.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You should be able to reach phpmyadmin with:

    if thats no the cae, then you most likely did not choose to configure apache for phpmyadmin during installtion. run:

    dpkg-reconfigre phpmyadmin

    and ensure that you check the option to configure apache for phpmyadmin. Then restart apache.
  3. Scot

    Scot New Member

    Hi, thanks for responding, I appreciate it.

    I tried which comes up with URL not found. is one of the sites I created in ISPConfig. Is there something I need to do to attach phpmyadmin to a particular site/domain?

    I've also tried the server url from the install tutorial,, but that doesn't work either.

    Several forum posts mentioned the dpkg-reconifigure phpmyadmin solution and I tried that more than once (and restarting apache). I get the option of apache or lighthttpd (or something like that) and choose apache. I've done this twice, but it doesn't fix the phpmyadmin location not found issue.

    I've seen a few people talk about attaching phpmyadmin to a site/domain, so maybe that's my next step. It seems pretty complicated so I'm hoping there's an easier way before I get into that, though.
  4. Scot

    Scot New Member

    Found the solution! This should be added to the perfect server install tutorial. Once I did this:

    ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
    a2enconf phpmyadmin
    service apache2 reload

    then I could access it via my ip like this:

Share This Page