phpmyadmin uploads do not work

Discussion in 'Installation/Configuration' started by teves, May 16, 2013.

  1. teves

    teves Member

    Hello,

    I have a problem with phpmyadmin uploads. Whenever I try to upload database scripts I get the following error:
    "Es wurden keinen Daten zum importieren empfangen. Entweder wurde keine Datei ausgewählt, oder die Dateigröße hat die maximal erlaubte Größe der PHP Konfiguration überschritten. Siehe FAQ 1.16."

    I have tried every hint of the FAQ 1.16, and also read and applied a lot of hints from posts of people having similar problems, but to no avail.
    I can state that it is NOT a problem of the upload size, for I have tried upload with a 4kB file and my upload limit is 38M, as shown by phpmyadmin itself.

    In the phpmyadmin configuration no upload directory is set, and no upload_tmp_dir is specified in the php.ini either; I am not sure if this is correct. Could anybody tell me please?

    When I use bigger files, the upload seems to take place and I get the error afterwards. So I thought it might be a permissions problem; The upload perhaps goes to some directory where phpmyadmin has no permission to read.

    The system is: Debian Squeeze, Mysql 5.1.66-0+squeeze1, Apache 2.2.16, PHP 5.3.3-7+squeeze15, Ispconfig 3.0.5.1

    Does anybody have an idea?

    regards, Tom
     
  2. falko

    falko Super Moderator

    What are the values of post_max_size and upload_max_filesize in /etc/php5/apache2/php.ini?

    Are there any errors in Apache's error log?
     
  3. teves

    teves Member

    Hello,

    the values are:
    post_max_size = 40MB
    upload_max_filesize = 38MB

    There are no errors in /var/log/apache2/error.log


    Regards, Tom
     
  4. monkfish

    monkfish New Member

    I had some similar symptoms a while back on one of my installs even when max upload size statements were good.

    Turned out that while the file HTTP(S) upload occured correctly, phpmyadmin was trying to process the file as a "LOAD DATA INFILE" statement.

    From memory there's a global permission to set to allow the specified user to perform INFILE commands.

    Wonder if you're seeing similar?
     
  5. teves

    teves Member

    That does not seem to be the case.

    Setting the upload directory does not help either. I have no clue...

    Can I just re-install phpmyadmin? How would I do that without harming the configuration of the Server?

    Regards, Tom
     
  6. monkfish

    monkfish New Member

    You can indeed reinstall phpmyadmin at any time you like. Should not affect the rest of the services.

    If you suspect its your phpmyadmin install, you could use a second deployment to test - why not add a virtual host to your dns and ispconfig as a separate website, and deploy phpmyadmin into there.

    For example, phptools.yourdomain.com

    - add A host dns entries pointing to your server
    - create ispconfig webiste site for domain
    - download phpmyadmin and unpack to web folder, set file permissions as necessary
    - run install script to generate config file and save
    - access that copy of phpmyadmin by http(s)://phptools.yourdomain.com
    - perhaps if you wanted simple added security password protect the folder you put it in.

    If that installation works, you've got a problem with the original and you could compare things like config files, permissions, etc. If it doesnt work you might have another issue manifesting itself.
    You can wipe the virtual site once you've completed your testing.

    My 0.02
     
  7. bch

    bch New Member

    I'm not 100% sure if it matters, but the proper way of declaring the size in megabytes is by using "M" and not "MB", according to http://www.php.net/manual/en/ini.core.php.

    post_max_size = 40M
    upload_max_filesize = 38M
     

Share This Page