phpMyAdmin update - ISPConfig Apache restart

Discussion in 'Tips/Tricks/Mods' started by wpwood3, Oct 28, 2007.

  1. wpwood3

    wpwood3 New Member

    Not a question. Just sharing my experience here in case it can help others...

    Today I used the Update Manager to update phpMyAdmin to the latest version that's available on the ISPConfig Downloads page (thanks Hans!). Here's what I did:

    1) Remove the old phpMyAdmin:
    rm -rf /home/admispconfig/ispconfig/web/phpmyadmin
    rm /home/admispconfig/ispconfig/web/phpmyadmin.tar.gz
    rm -rf /home/admispconfig/ispconfig/web/tools/tools/phpmyadmin
    2) Upload & install the new phpMyAdmin directly from the ISPConfig website using Update Manager.
    Select "URL" in update manager and paste the url for phpMyAdmin into the URL field:
    Click Install

    What could be easier right? :rolleyes:

    Well, everything installed but phpMyAdmin would not run. :eek:
    My browser would just hang and not connect. So I thought, simple, I just need to restart Apache. I restarted Apache in ISPConfig under Management > Server > Services. Still, phpMyAdmin refused to work. :mad:

    Then I remembered that ISPConfig uses its own Apache and maybe phpMyAdmin is running on that Apache. Sure enough, that's the case.

    3) I restarted the ISPConfig service (which includes Apache) and all was well.:D
    Here's how:

    /etc/init.d/ispconfig_server restart
    service ispconfig_server restart
    Last edited: Oct 28, 2007
  2. minimalist

    minimalist New Member

    The fact is you just have to wait a few minutes after you install a pkg. Also updated the phpMyAdmin today and it took up to 3 minutes untill it worked. We just waited longer and it worked like a charm.
  3. wpwood3

    wpwood3 New Member

    I didn't know that. When I installed the earlier version of phpMyAdmin it worked immediately so I got concerned when this one did not. Oh well, restarting the ISPConfig service works for sure.
  4. Hans

    Hans Moderator ISPConfig Developer

Share This Page