Phpmyadmin update error code 1?

Discussion in 'Installation/Configuration' started by treavle, Dec 15, 2009.

  1. treavle

    treavle New Member

    I tried to update my server through apt-get update, also ispconfig installation got that error.

    Code:
    The following packages have been kept back:
      linux-image-2.6-686
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    ispconfig:/tmp/ispconfig3_install/install# apt-get phpmyadmin
    E: Invalid operation phpmyadmin
    ispconfig:/tmp/ispconfig3_install/install# apt-get install phpmyadmin
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
      phpmyadmin
    0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
    Need to get 2884kB of archives.
    After this operation, 10.4MB of additional disk space will be used.
    Get:1 http://security.debian.org lenny/updates/main phpmyadmin 4:2.11.8.1-5+lenny3 [2884kB]
    Fetched 2884kB in 3s (953kB/s)
    Preconfiguring packages ...
    Selecting previously deselected package phpmyadmin.
    (Reading database ... 36262 files and directories currently installed.)
    Unpacking phpmyadmin (from .../phpmyadmin_4%3a2.11.8.1-5+lenny3_all.deb) ...
    Processing triggers for man-db ...
    Setting up phpmyadmin (4:2.11.8.1-5+lenny3) ...
    chmod: cannot access `/var/lib/phpmyadmin/config.inc.php': No such file or directory
    dpkg: error processing phpmyadmin (--configure):
     subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
     phpmyadmin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /var/lib/phpmyadmin
    ?
     

Share This Page