phpmyadmin stop working

Discussion in 'Installation/Configuration' started by pecka33, Dec 29, 2020.

  1. pecka33

    pecka33 Member

    Hi, i have a problem. yesterday i change my apache file - nothing to do with phpmyadmin, just add alias for my conf file for domain - not apache2.conf. I reload apache and then i can not get to phpmyadmin, https://ip/phpmyadmin/ i get error The requested URL was not found on this server. I am not sure what can i to do, i tried to back changes, but nothing work. in conf-enabled i can not see phpmyadmin.conf, so i tried to copy there, but still same problem, i tried to make copy file of phpmyadmin from usr/share to var/www

    thank you for help
     
  2. pecka33

    pecka33 Member

    No i check apache error log and there can i see errors like

    Code:
    [Tue Dec 29 08:16:08.157500 2020] [autoindex:error] [pid 5258] [client 94.112.151.194:59592] AH01276: Cannot serve directory /usr/share/phpmyadmin/: No matching DirectoryIndex (index.php) found, and server-generated directory index forbidden by Options directive
    
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    What did you add to which file?
    What is the content of /usr/share/phpmyadmin?
    Code:
    ls -la /usr/share/phpmyadmin/
     
  4. pecka33

    pecka33 Member

    Thank you. With command i can see
    Code:
    [email protected]:~# ls -la /usr/share/phpmyadmin/
    total 316
    drwxr-xr-x  11 root root 20480 Dec 29 09:31 .
    drwxr-xr-x 231 root root 12288 Dec 29 09:16 ..
    -rw-r--r--   1 root root  1560 Mar 21  2020 ajax.php
    -rw-r--r--   1 root root 17232 Mar 21  2020 ChangeLog
    -rw-r--r--   1 root root  3216 Mar 21  2020 CODE_OF_CONDUCT.md
    -rw-r--r--   1 root root  3299 Mar 21  2020 composer.json
    -rw-r--r--   1 root root 93882 Mar 21  2020 composer.lock
    -rw-r--r--   1 root root  2109 Mar 21  2020 CONTRIBUTING.md
    -rw-r--r--   1 root root  1038 Mar 21  2020 db_multi_table_query.php
    -rw-r--r--   1 root root  1816 Mar 21  2020 DCO
    drwxr-xr-x   2 root root  4096 Apr  2  2020 examples
    drwxr-xr-x   4 root root 12288 Dec 14 09:53 js
    drwxr-xr-x   5 root root 28672 Dec 14 09:53 libraries
    -rw-r--r--   1 root root 18092 Mar 21  2020 LICENSE
    drwxr-xr-x   7 root root  4096 Dec 14 09:53 locale
    -rw-r--r--   1 root root   729 Mar 21  2020 package.json
    -rw-r--r--   1 root root  1594 Mar 21  2020 prefs_twofactor.php
    -rw-r--r--   1 root root  1520 Mar 21  2020 README
    -rw-r--r--   1 root root    29 Mar 21  2020 RELEASE-DATE-4.9.5
    -rw-r--r--   1 root root    26 Mar 21  2020 robots.txt
    drwxr-xr-x   3 root root  4096 Dec 14 09:53 setup
    drwxr-xr-x   2 root root  4096 Dec 14 09:53 sql
    drwxr-xr-x  19 root root  4096 Dec 14 09:53 templates
    drwxr-xr-x   4 root root  4096 Dec 14 09:53 themes
    drwxr-xr-x  14 root root  4096 Apr  2  2020 vendor
    -rw-r--r--   1 root root 36017 Mar 21  2020 yarn.lock
    
    I think there should be index.php etc., but not sure, because before apache reload everything working fine. Maybe i should trie download phpmyadmin and reupload files.

    In apache file for my domain i just add alias in sites-available
    Code:
    ServerAlias *.domain.cz domain.cz 
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    If ISPConfig manages your webserver, add aliases through ISPConfig, not manually.

    There are files missing, try reinstalling PHPMyAdmin according to the perfect server tutorial.
     
  6. pecka33

    pecka33 Member

    Thank you, problem was solved. I reupload files from backup, reload apache and working fine.

    At last, i found that there was redirect to PhpMyAdmin, but should be used phpmyadmin. Now works fine..
    Thanks.
     

Share This Page