/phpmyadmin /roundcube /net2ftp

Discussion in 'Server Operation' started by erosbk, Apr 24, 2011.

  1. erosbk

    erosbk New Member

    I have working /phpmyadmin for EVERY vhost that I create on apache using ISPConfig3.

    /roundcube and /net2ftp are only working for my default page (IP/roundcube, IP/net2ftp, i Can access using my default domain too -it has no vhost created, only de dns records :p-)

    I can access /phpmyadmin using EVERY vhost domain, but I have error 500 when I try to access /roundcube and /net2ftp using vhosts...

    How can I make it work?

    - If this is not possible, how can I make to access roundcube and net2ftp using subdomain.everyvhost.com ???? I make a subdomain and redirected it to www.mydefaultdomain.com/roundcube, but it changes the URL, I want the users stay in URL subdomain.everyvhost.com...

    I beg your pardon for my poor explanation, I will rewrite this post if you don't understand :p

    Thank you in advance!
  2. erosbk

    erosbk New Member

    Ok, I find that this in each vhost file is preventing /rouncube and /net2ftp to work:

    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None

    Someone knows if this are default parameters in each vhost created by ispconfig3 or if are default of apache for each new virtual host? do someone knows how to change it? If I delete those, /roundcube and /net2ftp works perfectly for each vhost (like /phpmyadmin). I don't know if I have to replace SetHandler None for phpblablabla or if it affects something or not...

    Thanks for your help!
  3. erosbk

    erosbk New Member

    Ok, I think that ISPConfig3 is creating this directive... could you please explain me why are there? is for security reason? is it possible to change them by default when creating a new virtual host?

    Thank you very much (I need to modify this because I wish that every user could access /webmail and /net2ftp from their own domain).

    Thank you very much in advance.
  4. erosbk

    erosbk New Member

    Ok, in /etc/apache2/conf.d/roundcube I added this line:

    AddType application/x-httpd-php .php .php3 .php4 .php5

    Now, I can access www.allvhosts.com/webmail from every vhost if them are not set to use CGI as php.

    I have no problem with domains using FastCGI, Mod_PHP and suPHP (selected in ispconfig).

    I can't make it work for sites with CGI enabled as PHP... if someone can help me please... I have tried with SetHandler None after AddType, etc... I can't make it work like PMA... it works perfectly for each vhost....

    thank you very much...

    edit: if I # the following lines in the vhost conf. file, it works... but is not the solution...
    # AddHandler php5-cgi .php .php3 .php4 .php5

    I have tried RemoveHandler .php .php3 .php4 .php5 in roundcube conf file, but is not working...
    Last edited: Apr 28, 2011
  5. erosbk

    erosbk New Member

    Fixed, I learned a lot traying to make this work xD

    sed -i '1 i AddHandler application\/x-httpd-php .php .php3 .php4 .php5' /usr/share/roundcube/.htaccess
    sed -i '/Directory \/var\/lib\/roundcube\/>/a\
    php_admin_value open_basedir none' /etc/apache2/conf.d/roundcube

    If you want every page be able to access /roundcube (or whatever), you just need to add the php handler in the .htaccess of roundcube (use the sed instructions above to add it automatically).

    Please, if someone else can try and next post here the results, will be perfect!

    Last edited: Apr 28, 2011

Share This Page