phpmyadmin php files not recognized

Discussion in 'General' started by maumar, Jun 9, 2013.

  1. maumar

    maumar New Member HowtoForge Supporter

    I have installed a debian7-apache perfect server:

    Code:
    
    http://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3-p4
    
    When i try to access phpmyadmin, browser ask me to save inidex.php.

    I have changed into suPHp like here
    Code:
    
    vi /etc/apache2/mods-available/suphp.conf
    
    ... and comment out the <FilesMatch "\.ph(p3?|tml)$"> section and add the line AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml - otherwise all PHP files will be run by SuPHP
    
    
    so, that cannot be the issue.
    I have added
    Code:
                    php_admin_value engine on
    
    
    into /etc/phpmyadmin/apache.conf to get

    Code:
    
    
    <Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php
    
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
                    php_admin_value engine on
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_admin_flag allow_url_fopen Off
                    php_value include_path .
                    php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                    php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
            </IfModule>
    
    </Directory>
    
    
    what do I miss?
     

Share This Page