phpMyAdmin Not Working

Discussion in 'HOWTO-Related Questions' started by Woody619, Jun 13, 2011.

  1. Woody619

    Woody619 New Member

  2. btaylor

    btaylor New Member

    The httpd.conf file is probably empty, thats what I found on my setup.

    to fix go to /etc/apache2/
    delete http.conf
    Copy apache.conf from /etc/phpmyadmin/ to /etc/apache2/
    then rename it to http.conf

    restart apache and you should see the login page for phpmyadmin.
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Did you see all other test pages from that tutorial, so the basic apache's "it work's page" as well as the php info page?

    Mabye you might want to check the logs first, before just moving and deleting any config file (eventually without a backup).
    So just check e.g. /var/log/apache/access.log or error.log.
    This should give you some 404 errors or similar and also an idea where the webserver tried to find your requested page and you should then check where your phpmyadmin files have gone...
    The log path might differ depending on you distribution and package, it could also be /var/log/httpd or apache2.

    But maybe you just missed step 7 to reconfigure apache2 automatically? I don't know the phpmyadmin package that's used in the tutorial but I could imagine that it is an issue of a missing symlink in /etc/apache2/sites.enabled to point to the phpmyadmin one in the sites available dir.

Share This Page