phpMyAdmin not working after upgrading to

Discussion in 'General' started by fransyozef, Aug 15, 2013.

  1. fransyozef

    fransyozef New Member


    I've just upgraded to ISPConfig .. now when I want to go to phpmyadmin, the document isn't parsed by PHP


    Any idea's where to look?

    And sometimes I get a popup window to save the document because

    "application/x-httpd-suphp (6.5 KB"
    Last edited: Aug 15, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. fransyozef

    fransyozef New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This is correct for ISPConfig versions until 3.0.4 but starting with ISPConfig 3.0.5, no access to other applications over the ispconfig vhost is allowed for security reasons.
  5. fransyozef

    fransyozef New Member


    But I've also got another server with ISPConfig (this was a clean install, not an update) and from there I can access phpmyadmin from the ISPConfig Dashboard.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you dont access phpmyadmin trough the ispconfig vhost on that server, otherwise it wont be accessible. Compare the two apache phpmyadmin.conf files on both servers and adjust the file on the not working server.
  7. fransyozef

    fransyozef New Member

    THNX! That solved it .. I just copied the conf from server 2 (the working one) to server 1, restarted apache and yay!
  8. orasis

    orasis Member

    I've just noticed the problem as well, I have no way to access phpmyadmin anymore. As far as I remember I haven't touched any settings related to the phpmyadmin paths.

    The only thing I haven't done while updating to version was not to create a new SSL. but all SSL related stuff appears not to have any issue on any site or the server even.

    What shall I check ?
    cheers thanks for the help

    This is on Ubuntu 12.04 i386

    EDIT 2:
    Is this setting correct check the image ?

    Last edited: Aug 23, 2013
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    This depends on your server setup and phpmyadmin configuration. The oath there has to match the path were you installed phpmyadmin to.
  10. orasis

    orasis Member

    All default. I haven't changed anything. The installation of ispconfig 3 was done the way the tutorial for Ubuntu 12.04 describes.
    And this is what I am saying, I haven't changed any configuraiton related to phpmyadmin.
  11. orasis

    orasis Member

    ok I just found out that phpmyadmin is not installed.
    I looked in the /var/log/apt/history.log and saw this:
    Start-Date: 2013-08-23  01:19:34
    Commandline: aptdaemon role='role-remove-packages' sender=':1.68'
    Remove: phpmyadmin:i386 (, dbconfig-common:i386 (1.8.47)
    End-Date: 2013-08-23  01:20:19
    This is not good.
    Is there any workaround so that I don't reinstall everything ?
    The biggest problems is the databases.

Share This Page