PHPMyadmin not work

Discussion in 'Installation/Configuration' started by thenicespider, Apr 9, 2009.

  1. thenicespider

    thenicespider New Member

    Everything is ok instead PHPMyadmin.

    When I open http://ip_address/phpmyadmin or then error:
    - The requested URL /phpmyadmin was not found on this server.

    I have create a symlink for phpMyAdmin:
    ln -s /srv/www/htdocs/phpMyAdmin /usr/local/ispconfig/interface/web/phpmyadmin

    Any idea how to fix this error.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to enter the port. If you created a symlink /usr/local/ispconfig/interface/web/phpmyadmin then phpmyadmin is accessed with:

  3. thenicespider

    thenicespider New Member

  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /srv/www/htdocs/phpMyAdmin/
  5. Horfic

    Horfic Member

    I know now how to get phpmyadmin to work for the domains when the website has a ip selected. AND NOT * AS IP
    ln -s /var/www/phpmyadmin /var/www/{domain}/phpmyadmin
    So my question is, what do I have to change that ISPConfig create this symbolic link automatic, when you create a website.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can e.g. edit the apache plugin or write your own plugin.
  7. thenicespider

    thenicespider New Member

    Output of ls -la /srv/www/htdocs/phpMyAdmin/

    Output of ls -la /srv/www/htdocs/phpMyAdmin/ is:

    svr1:~ # ls -la /srv/www/htdocs/phpMyAdmin/

    total 1240
    drwxr-xr-x 8 root root 4096 Apr 9 17:45 .
    drwxr-xr-x 4 root root 4096 Apr 9 01:59 ..
    -rw-r--r-- 1 root root 227902 Mar 31 18:04 Documentation.html
    -rw-r--r-- 1 root root 6813 Mar 31 18:04 index.php
    -rw-r--r-- 1 root root 411 Mar 31 18:04 license.php
    -rw-r--r-- 1 root root 12043 Mar 31 18:04 main.php
    -rw-r--r-- 1 root root 25840 Mar 31 18:04 navigation.php
    -rw-r--r-- 1 root root 52856 Mar 31 18:04 pdf_schema.php
    lrwxrwxrwx 1 root root 26 Apr 9 17:45 phpMyAdmin -> /srv/www/htdocs/phpMyAdmin
    -rw-r--r-- 1 root root 360 Mar 31 18:04 phpinfo.php
    ....... etc ........
  8. baskin

    baskin Member

  9. XRolando

    XRolando New Member

    Exact same issue on opensuse 11.1.
  10. catalyst

    catalyst New Member

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Set the correct hostname for the server in the ispconfig server settings.
  12. catalyst

    catalyst New Member

    Yes! The hostname is correct. It is the same as the hostname when I installed the Cent OS.
    Any other issue?
    Thank you!
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. But ispconfig is doing the phpmyadmin redirect to the hostname that you have set in ispconfig server settings, if the redirect goes to a wrong hostname / domain, then it can not be set correctly in ispconfig. There is no other option, so please check again and compare the domain / hostname you get redirected to with the settings in ispconfig.
  14. Stojc

    Stojc New Member

    I think it can be corrected and phpmyadmin will then work on any domain and on the right port. Simply open file database_phpmyadmin.php in /var/www/ispconfig/sites/ and look for line

    header('location:' . $http . '://' . $serverData['server_name'] . '/phpmyadmin'); (not sure why is this rewrite needed - except if you want
    always to come in from same address)

    and replace it with


    Save it and then try. On my server works fine.
  15. BorderAmigos

    BorderAmigos New Member

    I had this same problem with 3.0.2. The port number is lost when the link is clicked and it is trying on port 80.

    I changed the line above to include the port number and it now works...
    header('location:' . $http . '://' . $serverData['server_name'] . ':8080/phpmyadmin');
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    The above does not apply to ISPConfig 3.0.2 anymore, in ISPConfig 3.0.2, you set the link to phpmyadmin under System > Interface Config. So instead of modifying any code, enter the URL to phpmyadmin in the interface config settings.
  17. BorderAmigos

    BorderAmigos New Member

    Thank you. I did not know that.
  18. Stojc

    Stojc New Member

    Thanks, Till. I also noticed that, but few days later (after I changed the code).

  19. menahem

    menahem Member


    It did not worked for me.:(

    phpmyadmin was installed by apt-get. (we are talking about debian etch - 4.0r8)

    At /var/www lib i have a link to:/usr/share/phpmyadmin.

    At ispconfig (ver -->system-->interface config-->PHPMyAdmin URL i inserted: www.domain.tld.

    www.domain.tld is the FQDN for the 1 domain hosted by the server i.e server domain name (server it self) lets say is server full domain name (after running hostname -f)=

    Now: 1st. web site is...

    Putting the URL in ispconfig (ver -->system-->interface config-->PHPMyAdmin URL i am getting a (nice looking) 404.

    Please advice hoto fix it.
    Thank you.
  20. miguelal

    miguelal New Member

    I had the exact same problem. You probably already fixed it but in the interest of helping any others that stumble upon this thread:

    Appending the following line to /etc/apache2/apache2.conf did it for me:

    Include /etc/phpmyadmin/apache.conf

Share This Page