phpmyadmin not found

Discussion in 'Installation/Configuration' started by toux, Sep 28, 2010.

  1. toux

    toux New Member

    Hello all!

    I have a trouble in other server with ispconfig 3.0.2

    Whem I click on Db access on the control panel show "Not found" when I try to access as root typing main Ip of the server /phpmyadmin show not found too.

    What can be the problem? Thank you very much!
     
  2. juan_g

    juan_g New Member

    Alias?

    Do you have the line:

    Alias /phpmyadmin /usr/share/phpmyadmin

    in:

    /etc/apache2/conf.d/phpmyadmin.conf
    /etc/phpmyadmin/apache.conf

    ?

    Did you follow a tutorial to install ISPConfig? For what Linux distribution: Ubuntu, Debian...?
     
    Last edited: Sep 29, 2010
  3. toux

    toux New Member

    Hello Juan

    Yes I have both published this alias on both files.

    I don know what is happened.

    /etc/apache2/conf.d/phpmyadmin.conf
    /etc/phpmyadmin/apache.conf

    I checked but....

    I use Debian 5.0 Lenny, yes i follow the steps for install like this tutorial, but for install 3.0.1 and after I update to 3.0.2

    Thanl you for your reply ;-)
     
  4. juan_g

    juan_g New Member

    With the alias, and if http://[IP number] or http://example.com works, then http://[IP number]/phpmyadmin or http://example.com/phpmyadmin should work, or also a workaround I used on a previous installation.

    When the URL works, you can enter it in:

    System -> Interface Config -> Sites -> phpMyAdmin URL

    and it will work in:

    Sites -> Database -> linked icon for each database
     
  5. tef

    tef New Member

    Same problem there
    i followed the step by step ubuntu 10.04 guide.

    /etc/apache2/conf.d/phpmyadmin.conf
    this file doesn't exists.

    I've created with alias directive (allow etc are not allowed) is it fine?
     
  6. falko

    falko Super Moderator

    What are the outputs of
    Code:
    updatedb
    locate phpmyadmin.conf
    and
    Code:
    ls -la /etc/apache2/conf.d/
    ?
     
  7. tef

    tef New Member

    /etc/apache2/conf.d/phpmyadmin.conf (i've added phpmyadmin in this folder before i don't know why he doesnt exists)
    /etc/dbconfig-common/phpmyadmin.conf
    /var/lib/dpkg/info/phpmyadmin.conffiles
    /var/lib/dpkg/info/phpmyadmin.config
    /var/lib/ucf/cache/:etc:dbconfig-common:phpmyadmin.conf


    drwxr-xr-x 2 root root 4096 2010-10-01 16:02 .
    drwxr-xr-x 7 root root 4096 2010-10-01 12:58 ..
    -rw-r--r-- 1 root root 237 2010-08-19 05:22 apache2-doc
    -rw-r--r-- 1 root root 269 2010-08-19 07:19 charset
    lrwxrwxrwx 1 root root 45 2010-10-01 12:59 javascript-common.conf -> /etc/javascript-common/javascript-common.conf
    -rw-r--r-- 1 root root 3296 2010-08-19 07:19 localized-error-pages
    -rw-r--r-- 1 root root 161 2010-10-01 15:03 phpmyadmin.conf
    -rw-r--r-- 1 root root 1481 2010-08-19 07:19 security
     
  8. toux

    toux New Member

    Hello Falko

    Mine is

    cdn1:/usr/share/phpmyadmin# locate phpmyadmin.conf
    /etc/apache2/conf.d/phpmyadmin.conf
    /var/lib/dpkg/info/phpmyadmin.conffiles
    /var/lib/dpkg/info/phpmyadmin.config


    And

    cdn1:/usr/share/phpmyadmin# ls -la /etc/apache2/conf.d/
    total 24
    drwxr-xr-x 2 root root 4096 2010-10-02 01:28 .
    drwxr-xr-x 8 root root 4096 2010-10-01 17:58 ..
    -rw-r--r-- 1 root root 237 2009-07-14 22:05 apache2-doc
    -rw-r--r-- 1 root root 269 2009-07-14 22:00 charset
    lrwxrwxrwx 1 root root 28 2010-07-01 20:54 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
    -rw-r--r-- 1 root root 1464 2009-07-14 22:00 security
    -rw-r--r-- 1 root root 1253 2009-08-25 17:29 squirrelmail.conf


    Thank you!

    David
     
  9. falko

    falko Super Moderator

    How did you create the file? What's in it?

    What's in this file? Maybe we can use it for the Apache configuration.
     
  10. falko

    falko Super Moderator

    What's in /etc/apache2/conf.d/phpmyadmin.conf?
     
  11. toux

    toux New Member

    Hello Falko thank you for your reply

    This is the content of the file

    # phpMyAdmin default Apache configuration

    Alias /phpmyadmin /usr/share/phpmyadmin

    <Directory /usr/share/phpmyadmin>
    DirectoryIndex index.php
    AddHandler fcgid-script .php .php3 .php4 .php5

    FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
    Options +ExecCGI Indexes FollowSymLinks
    AllowOverride all
    Order allow,deny
    Allow from all

    # Authorize for setup
    <Files setup.php>
    # For Apache 1.3 and 2.0
    <IfModule mod_auth.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    # For Apache 2.2
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    Require valid-user
    </Files>
    <IfModule mod_php4.c>
    AddType application/x-httpd-php .php
    FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    </Directory>


    <IfModule mod_rewrite.c>
    <IfModule mod_ssl.c>
    <Location /phpmyadmin>
    RewriteEngine on
     
  12. falko

    falko Super Moderator

    Can you make a backup of your current phpmyadmin.conf and use this instead?

    Code:
    # phpMyAdmin default Apache configuration
    
    Alias /phpmyadmin /usr/share/phpmyadmin
    
    <Directory /usr/share/phpmyadmin>
            Options Indexes FollowSymLinks
            DirectoryIndex index.php
    
            # Authorize for setup
            <Files setup.php>
                # For Apache 1.3 and 2.0
                <IfModule mod_auth.c>
                    AuthType Basic
                    AuthName "phpMyAdmin Setup"
                    AuthUserFile /etc/phpmyadmin/htpasswd.setup
                </IfModule>
                # For Apache 2.2
                <IfModule mod_authn_file.c>
                    AuthType Basic
                    AuthName "phpMyAdmin Setup"
                    AuthUserFile /etc/phpmyadmin/htpasswd.setup
                </IfModule>
                Require valid-user
            </Files>
            <IfModule mod_php4.c>
                    AddType application/x-httpd-php .php
    
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_value include_path .
            </IfModule>
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
    
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_value include_path .
            </IfModule>
    AuthType Basic
    AuthName "Members Only"
    AuthUserFile /usr/share/phpmyadmin/.htpasswd
    <limit GET PUT POST>
    require valid-user
    </limit>
    </Directory>
     
  13. toux

    toux New Member

    Hello Falko

    Thank you for your reply.

    Now I backup the old file and save the new, I try and nothing, but i change on interface config i write on phpmyadmin url phpmyadmin and try to acces by

    https://server-ip:8080/phpmyadmin

    And show this:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    EDIT:

    I try enter by the control panel selecting the database and:

    https://Server-ip:8080/sites/phpmyadmin

    and show: Not Found

    The requested URL /sites/phpmyadmin was not found on this server.

    Thank you
     
    Last edited: Oct 3, 2010
  14. toux

    toux New Member

    Please any idea to fix it?

    I have some scripts without control panel and i must access trought phpmyadmin for manage the sites, and is very important but i have not idea what can be the problem :(

    Thank you and greetens!
     
  15. tef

    tef New Member

    I think that the falco's configuration is for an url like

    http://serverip/phpmyadmin
    and not with ispconfig apache port.

    my file was only like this:

    #
    # Web application to manage MySQL
    #
    Alias /phpmyadmin /usr/share/phpmyadmin
    Alias /phpMyAdmin /usr/share/phpmyadmin
    Alias /mysqladmin /usr/share/phpmyadmin


    i will try ur suggestione
     
  16. tef

    tef New Member

    I've tryed ur suggestion.
    which user and password phpmyadmin try to read?
     
  17. toux

    toux New Member

    Hi Tef,

    thank you for your reply.

    I try write this alias but nothing...

    Y try with ssl certificacte, ispconfig port, without, all! but only i can see, the server missconfiguration with :8080/phpmyadmin and show a password and user, but not with phpmyadmin index.php.

    I write the root data login and after show the internal server error

    Thank you!
     
  18. tef

    tef New Member

    same to me.
    with the falco's script i can't get access
     
  19. toux

    toux New Member

    Hi Tef, I found a solution try this:

    Go to :/var/www/ispconfig/sites/database_phpmyadmin.php

    The last if replace for this code:

    if($global_config['phpmyadmin_url'] != '') {
    header('Location:'.$global_config['phpmyadmin_url']);
    } else {
    isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
    header('location:/phpmyadmin');
    }
    exit;
    ?>

    ===========================================
    After put the original phpconfig.conf on:

    /etc/apache2/conf.d/phpmyadmin.conf

    If you need the original file please say to me.

    and after them restart apache:

    /etc/init.d/apache2 restart


    For me work, I hope can work for you, if not i see on other forums, that if you try reconfigure phpmyadmin can be solved, but first try this better ;)

    Greetens!
     
  20. tef

    tef New Member

    Hi, thanks.

    This solve https problems or general problem for phpmyadmin?


    Yes i need the original.

    Now i'm really lost in this modifications.
    Why can't i return on default setting? phphmyadmin must run on same port of ispconfig? like myservername:8080/phpmyadmin?

    After ispconfig istallation i can't let phpmyadmin works. i solved adding a non existent file to the folder, and then phpmyadmin starts to work on normal path like a normal site. (not ispconfig port)
    This was incorrect right?
     
    Last edited: Oct 6, 2010

Share This Page