Phpmyadmin not found

Discussion in 'Installation/Configuration' started by Brian_A, Aug 22, 2009.

  1. Brian_A

    Brian_A New Member

    I've installed ISPConfig 3 according to the excellent "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]" by falko. Most things are working very well, so thank you for your good work.

    The problem I cannot seem to solve is I have no access to phpmyadmin, error 404 not found on server:- for or
    http://ipaddress/phpmyadmin or

    I guess I'm missing something either in the server setup or in ISPConfig setup, but I cannot see what. Could someone point me in the right direction please?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It might happen that you are not able to access phpmyadmin like this anymore if you assigned the IP of the server to a specific website. In this case I recommend that you create a website like phpmyadmin.mydomain.coma nd then install phpmyadmin into it.
  3. Brian_A

    Brian_A New Member

    Hi Till,

    As far as I can see we have not assigned an IP address to any specific web site. I did add the fqdn of the server to our external dns because ISPConfig uses a hyperlink with the server name. The same result from ISPConfig as you can see below.

    Not Found

    The requested URL /phpmyadmin was not found on this server.
    Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.1 with Suhosin-Patch mod_ssl/2.2.11 OpenSSL/0.9.8g Server at Port 80

    Could you suggest other possibilities?

  4. WayneKan1111

    WayneKan1111 New Member

    The tutorial said:
    Secure phpMyAdmin by deleting the /etc/phpmyadmin/htpasswd.setup file...
    vi /etc/phpmyadmin/apache.conf
    See if this works. Other distros work different.
    Where ever your phpmyadmin is. Symbolic link it to the /var/www/ file. since you have a LAMP system.
  5. Brian_A

    Brian_A New Member

    Hi WayneKan1111

    Yes you were right the symlink fixed the problem specifically:

    ln -s /usr/share/phpmyadmin /var/www/

    perhaps this should be added to the HowTo ???

    Thank you

  6. nhattywharl

    nhattywharl New Member

    wow .. although this thread is old .. I have been searching for ages for the solution of phpmyadmin not working. I have tried a billion things, ok maybe not a billion.. Anyway the code waynekan1111 and brian have written a was 100% spot on

    ln -s /usr/share/phpmyadmin /var/www/

    fixed just like that


Share This Page