phpMyAdmin log out problem

Discussion in 'HOWTO-Related Questions' started by ikaros, Aug 14, 2006.

  1. ikaros

    ikaros New Member

    I followed the perfect setup for Suse 10.1. Then, I installed phpMyAdmin with the ISPConfig update function and everything seems to work fine except from one detail. When i press the log out button, it asks for username and password. I enter them and it doesn't accept them, so the prompt appears again. The only way to stop this is by pressing the close button in the prompt window and then the following screen appears.

    http://rapidshare.de/files/29404574/wrong_account.JPG.html

    Any ideas?
     
    Last edited: Aug 14, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

  3. ikaros

    ikaros New Member

    thanx

    Although i didn't see that thread in the first place, now that i've read it, it's a bit different case than mine.

    I have a completely fresh installation of OpenSuse 10.1 and ISPconfig (with no sites, resellers etc) and haven't changed the root password in MySQL, which is what happyhd did in the thread you proposed. I can log in and out of ISPconfig, no problem there...and I can log in and use phpMyAdmin normally. When i log out from phpMyAdmin, it asks for a username and password. I have only one user (root) which is the user i used to log in initially. So I enter root's passwrod, but phpMyAdmin doesn't accept it and it shows a new prompt.
     
    Last edited: Aug 15, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    I guess you didn't read the whole thread I posted here? It's at the end.
     
  5. ikaros

    ikaros New Member

    OK, I read the thread more carefully this time, but I am in the same position as happyhd. When I log out from phpMyAdmin, I enter the same root password (which btw has no special characters) that exists into the variable $go_info["server"]["db_password"] in /home/admispconfig/ispconfig/lib/config.inc.php but I still don't have a "clean" log out.

    I believe this is a bug of phpMyAdmin for ISPconfig. If you think so too, where can i fill a bug report?
     
    Last edited: Aug 17, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    That's what I tried to explain in the thread: It's not a bug, that's the normal behaviour. Once you're logged out, phpMyAdmin shows you the login prompt. Nothing unusual here.
     
  7. ikaros

    ikaros New Member

    ok,ok I get it...

    ok, I misinterpreted the "cookie feeling" that was mentioned in the last posts of the thread.

    Maybe you should delete this whole thread since it's useless.

    Thanx again.
     
  8. baskin

    baskin New Member

    I have a similar problem after upgrading an old server from opensuse 11.1 to 11.2.

    Although i can login to phpmyadmin (versio 3.5.2) i cannot logout and also i cannot delete rows from a table.

    When i press the logout button, i get the home page and not a username-password prompt. Also inside a table i check all the rows and press delete but nothing happens (it says no rows selected).

    I have tried to solve it but i'm on dead end. Ispconfig is the latest 3.0.4.6

    Thanks in advance.
     
  9. baskin

    baskin New Member

    Found it.

    I have to change the absolute url on /etc/phpMyAdmin/config.inc.php.
     

Share This Page