Phpmyadmin issue (Virtual Users And Domains With Postfix, Courier And MySQL )

Discussion in 'HOWTO-Related Questions' started by tonkyman, Oct 20, 2008.

  1. tonkyman

    tonkyman New Member

    I have used the howto "Virtual Users And Domains With Postfix, Courier And MySQL" to set up a couple of servers and it's always worked fine if you follow the howto to the letter. Today I started setting up a new server for my office and I started noticing a few little things that relate to upgrades to some of the packages but I think I was able to work through all the issues except one.

    I have the server setup and tried to get into PHPmyadmin and it won't let me in. I get a 404 error as if it can't find the page. I went and looked at one of my other servers and noticeds that Apache2 is setup a bit different on that server even though I used the same howto and followed it step for step.

    I tried to set it up like the older computer (both are using ubuntu 8.04) but Apache gave me an error when it was restarting that said something about there being a duplicate directive. I removed the changes I made so the server is back to the configuration refered to in the howto.

    Does anyone have any ideas on what I need to do to make phpmyadmin work??

  2. hostchecker

    hostchecker New Member

    I'm having a very similar problem, anyone know?
  3. tonkyman

    tonkyman New Member

    A solution... sorta?

    O.K! I have it working but I'm not sure it's the correct way. On my old system there was a symbolic link in /etc/apache2/conf.d called phpmyadmin.conf and it points to /etc/phpmyadmin/apache.conf. I created the symbolic link and restarted apache and it appears to be working.

    The commands are:

    # this command creates the symbolic link
    ln -s /etc/phpmyadmin/apache.conf phpmyadmin.conf

    #this command restarts apache
    /etc/init.d/apache2 restart

    I hope this helps and that I'm not telling you wrong, It works for me.


Share This Page