phpMyAdmin import file size limit

Discussion in 'Installation/Configuration' started by Peter Veselý, Dec 7, 2017 at 4:21 PM.

  1. Peter Veselý

    Peter Veselý New Member

    Hi All.
    I've been trying to fix my database import problem for 3 days, please help. I have seen a large number of discussion forums and have tried all the possible steps without success.
    I need to import database in phpMyAdmin but there is upload file size limit Max: 2,048KiB - screen1
    [​IMG]
    In ISP Config I have set up in Sites->Options->Custom php.ini settings post_max_size = 250M and upload_max_filesize = 250M - screen2
    [​IMG]
    In phpinfo() I see the limit set correctly - screen3
    [​IMG]
    But in phpMyAdmin i have import file size limit Max: 2,048KiB

    Please help...

    OS Ubuntu 16.04.3 LTS (Xenial Xerus)) / ISPConfig 3.1.8p1
     
  2. PVasileff

    PVasileff Member

    If you download and extract another phpmyadmin and configure it in your /var/www/domain.com/web/ folder - your settings will work.

    phpMyAdmin installed from Perfect server howto doesnt use CGI. It use mod_php (Server API: Apache Handler).
    Create info.php in /usr/share/phpmyadmin/ file with content
    PHP:
    <?php phpinfo(); ?>
    to see that.

    To increase limits open
    Code:
    nano /etc/php/7.0/apache2/php.ini
    find
    upload_max_filesize and post_max_size and set 250M. After that - restart apache:
    Code:
    systemctl restart apache2
     
    Last edited: Dec 9, 2017 at 2:22 PM
  3. Peter Veselý

    Peter Veselý New Member

    Thank you Plamen Vasilev, it works !
     

Share This Page