phpmyadmin import error

Discussion in 'Server Operation' started by Sheshman, Jun 9, 2020.

Tags:
  1. Sheshman

    Sheshman Member

    Hi,
    Using latest version of ispconfig on Ubuntu 18.04, everything works perfectly but when i login to phpmyadmin through mydomain.com/phpmyadmin and click to import or export to import/export sql file attached errors showing up.

    When i click to ignore all PhpMyAdmin works wihtout any problem,importing sql file, exporting file, running queries etc.
    What causing this error and how i can fix it?
     

    Attached Files:

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Text in the popup is all greek to me. You could have changed the language to English for the screenshot.
    The error about "parameter must be an array ..." may be PHP version mismatch. The code is written to an older (or newer) version of PHP than is running on that host.
     
  3. nhybgtvfr

    nhybgtvfr Active Member

    that's errors a bug in the phpMyAdmin code.
    I can't remember the exact file, or place in the file off the top of my head. but it's an easy fix, just a bit of syntax changing.
    just put the error message and phpMyAdmin into google and you'll find the solution.
     
  4. Sheshman

    Sheshman Member

    well, in the pop-up says "Some errors occured,please check the below output" and the output is in English so i thought doesn't need to change language for a little text.
     
  5. Sheshman

    Sheshman Member

    Here is the solution if someone needs in future :

    Backup plugin_interface.lib.php :

    sudo cp /usr/share/phpmyadmin/libraries/plugin_interface.lib.php /usr/share/phpmyadmin/libraries/plugin_interface.lib.php.bak

    Edit plugin_interface.lib.php :
    pico /usr/share/phpmyadmin/libraries/plugin_interface.lib.php

    Press CTRL + W and search for if (! is_null($options) && count($options) > 0) {

    If not found, try search for if ($options != null && count($options) > 0)

    Replace with if (! is_null($options) && count((array)$options) > 0) {

    Save file and exit. (Press CTRL + X, press Y and then press ENTER)

    Orijinal Post : https://devanswers.co/problem-php-7-2-phpmyadmin-warning-in-librariessql-count/
     

Share This Page