phpmyadmin help

Discussion in 'Installation/Configuration' started by Nolan, Nov 30, 2010.

  1. Nolan

    Nolan Member

    Hi,

    I ran apt-get install phpmyadmin, and when I try to go to http://mywebsite.com/phpmyadmin, nothing happens. When I try to click the link on a client database to go to phpmyadmin, nothing happens either... Not sure what I did wrong this time.

    All services are now running now, woo hoo!
    I used this http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3 to set it up.

    Any help is greatly appreciated. :D

    EDIT: I uninstalled phpmyadmin, and reinstalled it and I'm not sure what happened, but I can't access http://serv1.mysite.com:8080 anymore, nor can I access http://serv1.mysite.com :(

    Thanks,

    Nolan
     
    Last edited: Nov 30, 2010
  2. till

    till Super Moderator

    To access phpmyadmin, use the IP address or hostname od the server and not the domain of a website that you created in ispconfig.

    Restart apache on the shell. If that dont work, post the error messages that you get in the apache error.log and on the shell.
     
  3. Nolan

    Nolan Member

    I was using the hostname of my server to try to access phpmyadmin.

    It also keeps saying that some of my components are outdated, but im not sure why... when I run apt-get update && apt-get upgrade it says everything is up to date.

    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following NEW packages will be installed:
    libbind9-50 libdns55 libisc52 libisccc50 libisccfg50 liblwres50
    The following packages have been kept back:
    pure-ftpd-common pure-ftpd-mysql
    The following packages will be upgraded:
    bind9utils libbind-dev
    2 upgraded, 6 newly installed, 0 to remove and 2 not upgraded.
    Inst libisc52 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst libdns55 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst libisccc50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst libisccfg50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst libbind9-50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst bind9utils [1:9.5.1.dfsg.P3-1+lenny1] (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst liblwres50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Inst libbind-dev [1:9.5.1.dfsg.P3-1+lenny1] (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libisc52 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libdns55 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libisccc50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libisccfg50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libbind9-50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf bind9utils (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf liblwres50 (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)
    Conf libbind-dev (1:9.6.ESV.R1+dfsg-0+lenny2 Debian:5.0.7/stable, Debian-Security:5.0/stable)


    It's also saying my ClamAV is out of date, how do I update that?

    Also, I ran apt-get upgrade and it seems to have upgraded the ftp-server and I thought I ran the commands to disable the upgrade process for that.

    serv1:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up pure-ftpd-mysql (1.0.21-11.4) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/
    etc/pure-ftpd/db/mysql.conf -l pam -D -H -b -E -u 1000 -A -O clf:/var/log/pure-f
    tpd/transfer.log -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
    subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
    pure-ftpd-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
    Last edited: Nov 30, 2010
  4. falko

    falko Super Moderator

    Do you have the line
    Code:
    deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
    in your /etc/apt/sources.list?
     
  5. Nolan

    Nolan Member

    It is now, thanks.

    to solve the FTP issue, should I uninstall the one I have? everything was working until I updated and it replaced the version that I have. :/

    Also, how do I fix the phpmyadmin? It never worked.
     
  6. cbj4074

    cbj4074 HowtoForge Supporter

    Are you sure that when you removed phpmyadmin, you didn't remove a number of dependent packages on which phpmyadmin relied in the process?

    If that is in fact the case, you have a lot of clean-up work to do!

    I'm not sure where FTP came into the thread; I thought this was about phpmyadmin not working.

    When you state, "when I try to go to http://mywebsite.com/phpmyadmin, nothing happens", that's not terribly helpful.

    If you see a blank page with no HTML output in the source, then Apache is responding to the request, in which case you should check the domain's log file at /var/www/domain.tld/log/error.log to see why Apache is complaining. It's probably an open_basedir restriction in PHP, or a permissions issue.
     
  7. Nolan

    Nolan Member

    It was about Phpmyadmin not working, but around the same time, that also broke. Why not hit 2 birds with one stone? :p

    I didn't really mean "nothing happens." I'm getting a 404 Error. Not sure why I worded it like that, but whatever.
     
  8. Nolan

    Nolan Member

    Any solutions?

    I would provide more information about what's wrong if I knew what to look for :/

    Thanks.
     
  9. Nolan

    Nolan Member

    Sorry to post again, but I was wondering if there's anything else that I should try?
    I don't really know where to begin in troubleshooting the issue.

    Thanks,

    Nolan
     
  10. till

    till Super Moderator

    Regarding phpmyadmin, please see my post #2. phpmyadmin is accessible trough the default vhost, which is only reachble when the IP is not assigned to a website. Do you select * or the IP address in your websites?
     
  11. Nolan

    Nolan Member

    * is the only option in there.

    My server was recently restarted, how do I get the MyDNS server back online?

    Thanks,

    Nolan
     
  12. falko

    falko Super Moderator

    Code:
    /etc/init.d/mydns start
     
  13. Nolan

    Nolan Member

    I don't think MyDNS started, Falko. the Services Status is still reporting it down as of a couple of minutes ago, and I did that command several minutes before that.
    Should I start another thread for the FTP issue? It kind of started around the same time, so I just grouped it into this one.

    -Nolan
     
  14. falko

    falko Super Moderator

    Any errors in the logs when you run
    Code:
    /etc/init.d/mydns restart
    ?

    That would be good.
     
  15. Nolan

    Nolan Member

  16. Nolan

    Nolan Member

    I'm still experiencing issues with this, so time to go back to this thread

    Okay, I followed the bind and dovecot way of installation this time, and the DNS server is now functioning correctly.

    However when I click the phpmyadmin button next to the database for my site it just says "Oops! This link appears to be broken." My website and ISPconfig are both on the same IP and domain.

    What should I do now?
     
  17. Nolan

    Nolan Member

    Problem Solved!

    I had to create a symlink so I just did
    Code:
    cd /var/www/clients/client1/web2/web
    ln -s /usr/share/phpmyadmin 
    The client and web number may differ depending on which website you want phpmyadmin to load on.
     

Share This Page