phpmyadmin failed to authenticate with correct password

Discussion in 'Installation/Configuration' started by bob50, Sep 6, 2016.

  1. bob50

    bob50 New Member


    Both SSL & non-SSL at <domain>:8080/phpmyadmin are available with a newly installed ISPConfig. Though login at both the link fail with correct mysql password of root user. Do we need any modification at /etc/phpmyadmin/ or need to look at other configuration ? Please suggest.
    Thanks for your valuable support
  2. Jesse Norell

    Jesse Norell Active Member

    phpmyadmin works out of the box on debian; what OS do you have and did you follow a Perfect Server guide to install or ?
  3. bob50

    bob50 New Member

    Hi Jesse,
    this is ubuntu 16.04 and yes, followed perfect server guide available at howtoforge. Can log into mysql as root at console but not through phpmyadmin. Please advise
  4. bob50

    bob50 New Member

    Jesse why mysql goes into mariaDB in ubuntu ?

    mysql -v
    Welcome to the MariaDB monitor. Commands end with ; or \g.
    Your MariaDB connection id is 17681
    Server version: 10.0.25-MariaDB-0ubuntu0.16.04.1 Ubuntu 16.04

    Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

    Reading history-file /root/.mysql_history
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    MariaDB [(none)]>
  5. Jesse Norell

    Jesse Norell Active Member

  6. bob50

    bob50 New Member

    Hi Jesse,
    the issue fixed by following steps
    echo "update user set plugin='' where User='root';" | mysql -root -p mysql
    service mysql restart

Share This Page