phpMyAdmin Error Messages

Discussion in 'Installation/Configuration' started by Milleman, Jul 27, 2009.

  1. Milleman

    Milleman New Member

    Hi,

    I've installed the phpMyAdmin (v3.2.0.1) from the "ICPConfig in Dutch" website:
    http://ispconfig.bb-hosting.org/uk/downloads.htm

    But it seems that I'm getting two error messages when I enter the phpMyAdmin. How do I resolve these?


    First one:
    "The additional features for working with linked tables have been deactivated. To find out why click here."

    $cfg['Servers'][$i]['pmadb'] ... not OK
    $cfg['Servers'][$i]['relation'] ... not OK
    General relation features: Disabled

    $cfg['Servers'][$i]['table_info'] ... not OK
    Display Features: Disabled

    $cfg['Servers'][$i]['table_coords'] ... not OK
    $cfg['Servers'][$i]['pdf_pages'] ... not OK
    Creation of PDFs: Disabled

    $cfg['Servers'][$i]['column_info'] ... not OK
    Displaying Column Comments: Disabled
    Bookmarked SQL query: Disabled
    Browser transformation: Disabled

    $cfg['Servers'][$i]['history'] ... not OK
    SQL history: Disabled

    $cfg['Servers'][$i]['designer_coords'] ... not OK
    Designer: Disabled


    Second message:
    "Your PHP parameter session.gc_maxlifetime is lower that cookie validity configured in phpMyAdmin, because of this, your login will expire sooner than configured in phpMyAdmin."

    Sincerely,
    /Mill
     
  2. Mark_NL

    Mark_NL New Member

  3. Milleman

    Milleman New Member

    In php.ini I found the:

    session.gc_maxlifetime = 1440

    What is the value of cookie validity configured in phpMyAdmin? Where can I find that?

    /M
     
  4. Mark_NL

    Mark_NL New Member

    check your config.inc.php of phpmyadmin? because i have no idea at the moment.

    i'd never had errors like that before with default intallations of all the software talked about in this thread, so something must've been changed, or missing in your config.
     
  5. Milleman

    Milleman New Member

    Okay,

    In the file you suggested, I've found it to be this:

    $cfg['LoginCookieValidity'] = 1800;

    I changed it to be 1440 instead, like in the php.ini file. Error/warning message is now gone!

    Thanks! :)
     
    Last edited: Jul 27, 2009

Share This Page